summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2013-09-08 22:51:43 +0100
committerRoger Leigh <rleigh@debian.org>2013-09-29 16:45:34 +0100
commit4a272b256ea0cae74cad442eca75363e9d8edb47 (patch)
tree1450526d5688bb52b058db50634cfef0a1f53624 /configure.ac
parentf71acb7a31d7932cf3d5f8aaa1682787c18b2127 (diff)
downloadschroot-4a272b256ea0cae74cad442eca75363e9d8edb47.tar.gz
build: Add cmake build infrastructure
This permits building using cmake rather than the existing autoconf/automake/libtool infrastructure. The autotools- based build may be removed in future commits, but either may be used until that point.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0d40a2d5..83ffeeda 100644
--- a/configure.ac
+++ b/configure.ac
@@ -364,6 +364,19 @@ AC_CHECK_FUNC([unshare],
[UNSHARE_FUNC="no"])
# Determine which features to enable.
+AC_MSG_CHECKING([whether to build NLS support])
+BUILD_NLS="yes"
+if test "$USE_NLS" = "no"; then
+ BUILD_NLS="no"
+fi
+AC_MSG_RESULT([$BUILD_NLS])
+
+AM_CONDITIONAL([BUILD_NLS], [test "$BUILD_NLS" = "yes"])
+AH_TEMPLATE(SBUILD_FEATURE_NLS, [Set if NLS support is present])
+if test "$BUILD_NLS" = "yes"; then
+ AC_DEFINE(SBUILD_FEATURE_NLS, 1)
+fi
+
AC_MSG_CHECKING([whether to build unshare support])
BUILD_UNSHARE="yes"
if test "$UNSHARE_HEADER" = "no"; then