summaryrefslogtreecommitdiff
path: root/debian/schroot.init
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2006-02-28 11:51:54 +0000
committerRoger Leigh <rleigh@debian.org>2006-02-28 11:51:54 +0000
commit5ae8c09d7a7a3453a0018d1f924cf27d334fb1e0 (patch)
treecd6d6c0acd0595de837c75e88aa3f3feab28d4be /debian/schroot.init
parentb455d90d076f936fe74b0c62e6a3357ff9243df8 (diff)
downloadschroot-5ae8c09d7a7a3453a0018d1f924cf27d334fb1e0.tar.gz
* debian/changelog: Update.
* debian/schroot.init: Rename $DAEMON to $SCHROOT. Don't exit with an error if session recovery for an individual chroot fails.
Diffstat (limited to 'debian/schroot.init')
-rwxr-xr-xdebian/schroot.init8
1 files changed, 4 insertions, 4 deletions
diff --git a/debian/schroot.init b/debian/schroot.init
index 84b70574..398852f7 100755
--- a/debian/schroot.init
+++ b/debian/schroot.init
@@ -2,11 +2,11 @@
#
# Recover schroot sessions.
-DAEMON=/usr/bin/schroot
+SCHROOT=/usr/bin/schroot
PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
NAME=schroot
-test -x $DAEMON || exit 0
+test -x $SCHROOT || exit 0
# Include #PACKAGE# defaults if available
#if [ -f "/etc/default/$NAME" ] ; then
@@ -18,9 +18,9 @@ set -e
recover_sessions()
{
echo -n "Recovering schroot sessions... "
- for chroot in `schroot --all-sessions --list --quiet`
+ for chroot in `$SCHROOT --all-sessions --list --quiet`
do
- schroot --chroot=$chroot --recover-session
+ $SCHROOT --chroot=$chroot --recover-session || true
echo -n "$chroot, "
done
echo "done."