summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2006-07-10 10:47:51 +0000
committerRoger Leigh <rleigh@debian.org>2006-07-10 10:47:51 +0000
commit264c05b99a656344fd3f63efc03750dc9ae5a595 (patch)
treeb2b6858bd4ca5fc4ce49ddb0614a4f0515bd1025 /debian
parentcffa08d3863fe8cac865188806f6fa6429401103 (diff)
downloadschroot-264c05b99a656344fd3f63efc03750dc9ae5a595.tar.gz
* debian/schroot.docs: Add the contents of debian/docs.
* debian/docs: Remove. * debian/rules: The /usr/share/doc directories for dchroot and dchroot-dsa are symlinks to schroot. * debian/dchroot.preinst: New file. Remove /usr/share/doc/dchroot. * debian/dchroot-dsa.preinst: New file. Remove /usr/share/doc/dchroot-dsa. * debian/changelog: Update.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog11
-rw-r--r--debian/dchroot-dsa.preinst41
-rw-r--r--debian/dchroot.preinst41
-rw-r--r--debian/docs3
-rwxr-xr-xdebian/rules6
-rw-r--r--debian/schroot.docs3
6 files changed, 99 insertions, 6 deletions
diff --git a/debian/changelog b/debian/changelog
index 25484493..dd0a374c 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -5,8 +5,15 @@ schroot (0.99.3-1) UNRELEASED; urgency=low
declared outside the class, in addition to the friend declaration.
This fixes a compilation error with GCC 4.2 (Closes: #377433). Thanks
to Martin Michlmayr for reporting this.
-
- -- Roger Leigh <rleigh@debian.org> Thu, 6 Jul 2006 19:07:25 +0100
+ * debian/schroot.docs: Add the contents of debian/docs.
+ * debian/docs: Remove.
+ * debian/rules: The /usr/share/doc directories for dchroot and
+ dchroot-dsa are symlinks to schroot.
+ * debian/dchroot.preinst: New file. Remove /usr/share/doc/dchroot.
+ * debian/dchroot-dsa.preinst: New file. Remove
+ /usr/share/doc/dchroot-dsa.
+
+ -- Roger Leigh <rleigh@debian.org> Mon, 10 Jul 2006 09:09:05 +0100
schroot (0.99.2-1) unstable; urgency=low
diff --git a/debian/dchroot-dsa.preinst b/debian/dchroot-dsa.preinst
new file mode 100644
index 00000000..7c8dc02f
--- /dev/null
+++ b/debian/dchroot-dsa.preinst
@@ -0,0 +1,41 @@
+#!/bin/sh
+# preinst script for dchroot-dsa
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+# * <new-preinst> `install'
+# * <new-preinst> `install' <old-version>
+# * <new-preinst> `upgrade' <old-version>
+# * <old-preinst> `abort-upgrade' <new-version>
+#
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+
+case "$1" in
+ install|upgrade)
+ if dpkg --compare-versions "$2" lt "0.99.3-1"; then
+ rm -rf /usr/share/doc/dchroot-dsa
+ fi
+ ;;
+
+ abort-upgrade)
+ ;;
+
+ *)
+ echo "preinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
+
+
diff --git a/debian/dchroot.preinst b/debian/dchroot.preinst
new file mode 100644
index 00000000..cd423faa
--- /dev/null
+++ b/debian/dchroot.preinst
@@ -0,0 +1,41 @@
+#!/bin/sh
+# preinst script for dchroot
+#
+# see: dh_installdeb(1)
+
+set -e
+
+# summary of how this script can be called:
+# * <new-preinst> `install'
+# * <new-preinst> `install' <old-version>
+# * <new-preinst> `upgrade' <old-version>
+# * <old-preinst> `abort-upgrade' <new-version>
+#
+# for details, see http://www.debian.org/doc/debian-policy/ or
+# the debian-policy package
+
+
+case "$1" in
+ install|upgrade)
+ if dpkg --compare-versions "$2" lt "0.99.3-1"; then
+ rm -rf /usr/share/doc/dchroot
+ fi
+ ;;
+
+ abort-upgrade)
+ ;;
+
+ *)
+ echo "preinst called with unknown argument \`$1'" >&2
+ exit 1
+ ;;
+esac
+
+# dh_installdeb will replace this with shell code automatically
+# generated by other debhelper scripts.
+
+#DEBHELPER#
+
+exit 0
+
+
diff --git a/debian/docs b/debian/docs
deleted file mode 100644
index 5502ed8f..00000000
--- a/debian/docs
+++ /dev/null
@@ -1,3 +0,0 @@
-NEWS
-README
-TODO
diff --git a/debian/rules b/debian/rules
index 8b237d65..85b2ab99 100755
--- a/debian/rules
+++ b/debian/rules
@@ -73,8 +73,12 @@ binary-indep: build install
binary-arch: build install
dh_testdir
dh_testroot
- dh_installchangelogs ChangeLog
+ dh_installchangelogs
dh_installdocs
+ rm -rf $(CURDIR)/debian/dchroot/usr/share/doc/dchroot
+ ln -sf schroot $(CURDIR)/debian/dchroot/usr/share/doc/dchroot
+ rm -rf $(CURDIR)/debian/dchroot-dsa/usr/share/doc/dchroot-dsa
+ ln -sf schroot $(CURDIR)/debian/dchroot-dsa/usr/share/doc/dchroot-dsa
dh_installexamples
dh_installman
dh_installinit --no-start --update-rcd-params='start 75 S .'
diff --git a/debian/schroot.docs b/debian/schroot.docs
index 7728b5ae..e14d8a80 100644
--- a/debian/schroot.docs
+++ b/debian/schroot.docs
@@ -1 +1,4 @@
+NEWS
+README
THANKS
+TODO