summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2013-09-07 23:25:46 +0100
committerRoger Leigh <rleigh@debian.org>2013-09-08 18:17:29 +0100
commit2b9a647c05e9f2b7ed636dda194cee31c056b2df (patch)
treed7fb678b9bf06e5f2e2d6c0e99296d6d16b8d7f7 /debian
parent3f2d64ab62eb92852b5c42389b2f4d1a94431464 (diff)
downloadschroot-2b9a647c05e9f2b7ed636dda194cee31c056b2df.tar.gz
debian: Bump version to 1.7.1-1 and add gtest support
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog8
-rw-r--r--debian/control2
-rwxr-xr-xdebian/rules12
3 files changed, 20 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index 0a1d5d37..7a145266 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,11 @@
+schroot (1.7.1-1) UNRELEASED; urgency=low
+
+ * New upstream development release.
+ * debian/control: Add cmake and gtest build dependencies.
+ * debian/rules: Build and configure gtest support.
+
+ -- Roger Leigh <rleigh@debian.org> Sat, 07 Sep 2013 23:24:40 +0100
+
schroot (1.7.0-1) experimental; urgency=low
* New upstream development release.
diff --git a/debian/control b/debian/control
index 5b5e1e5f..2df1eb91 100644
--- a/debian/control
+++ b/debian/control
@@ -6,6 +6,7 @@ Uploaders: Roger Leigh <rleigh@debian.org>
Build-Depends:
debhelper (>= 9),
autotools-dev,
+ cmake,
pkg-config,
libpam0g-dev,
libboost-dev,
@@ -15,6 +16,7 @@ Build-Depends:
libboost-filesystem-dev,
gettext,
libcppunit-dev,
+ libgtest-dev,
groff-base,
po4a (>= 0.40)
Build-Depends-Indep:
diff --git a/debian/rules b/debian/rules
index 3330230d..47fd5735 100755
--- a/debian/rules
+++ b/debian/rules
@@ -41,7 +41,13 @@ DH_INSTALL_FILES = $(basename $(wildcard debian/*.install.in))
override_dh_auto_configure: debian/build/config.status
-debian/build/config.status: configure
+debian/build/gtest/libgtest.a:
+ mkdir -p $(dir $@)
+ cd $(dir $@) ; \
+ CXX="g++ -std=c++11" cmake /usr/src/gtest ; \
+ make VERBOSE=1
+
+debian/build/config.status: configure debian/build/gtest/libgtest.a
dh_auto_configure -- \
--enable-dchroot --enable-dchroot-dsa \
--with-bash-completion-dir=/etc/bash_completion.d \
@@ -50,12 +56,14 @@ debian/build/config.status: configure
BTRFSCTL=/sbin/btrfsctl \
LVCREATE=/sbin/lvcreate \
LVREMOVE=/sbin/lvremove \
- CXX='g++ -std=gnu++11'
+ CXX='g++ -std=gnu++11' \
+ GTEST_ROOT="$(CURDIR)/debian/build/gtest"
dh_testdir
override_dh_auto_clean:
dh_auto_clean
rm -f $(DH_INSTALL_FILES)
+ rm -rf debian/build
rm -rf debian/install
override_dh_auto_build: