summaryrefslogtreecommitdiff
path: root/etc/CMakeLists.txt
diff options
context:
space:
mode:
authorRoger Leigh <rleigh@debian.org>2013-09-29 16:45:51 +0100
committerRoger Leigh <rleigh@debian.org>2013-09-29 16:45:51 +0100
commite1baf55e6d7b16bc47f7fee78019cabe113e7ef7 (patch)
tree25ef6b9a73d4e315901b9c9b3ad3647673f98c9b /etc/CMakeLists.txt
parentf71acb7a31d7932cf3d5f8aaa1682787c18b2127 (diff)
parent6c10fdfd1b43f5a4e2ac12b04ca082517092fbcd (diff)
downloadschroot-e1baf55e6d7b16bc47f7fee78019cabe113e7ef7.tar.gz
Merge branch 'cmake'
Diffstat (limited to 'etc/CMakeLists.txt')
-rw-r--r--etc/CMakeLists.txt73
1 files changed, 73 insertions, 0 deletions
diff --git a/etc/CMakeLists.txt b/etc/CMakeLists.txt
new file mode 100644
index 00000000..7500271c
--- /dev/null
+++ b/etc/CMakeLists.txt
@@ -0,0 +1,73 @@
+# Copyright © 2004-2013 Roger Leigh <rleigh@debian.org>
+#
+# schroot is free software: you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# schroot is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see
+# <http://www.gnu.org/licenses/>.
+#
+#####################################################################
+
+set(schroot_sysconf_data
+ schroot.conf)
+
+install(FILES ${schroot_sysconf_data}
+ DESTINATION ${SCHROOT_SYSCONF_DIR})
+
+set(files
+ copyfiles
+ fstab
+ nssdatabases)
+
+set(profiles
+ buildd
+ default
+ desktop
+ minimal
+ sbuild)
+
+set(arches
+ ${SBUILD_PLATFORM})
+
+foreach(profile ${profiles})
+ foreach(file ${files})
+ file(MAKE_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/profiles/${profile}")
+ set(output_file "${CMAKE_CURRENT_BINARY_DIR}/profiles/${profile}/${file}")
+ foreach(arch ${arches})
+ if(EXISTS ${output_file})
+ file(REMOVE ${output_file})
+ endif(EXISTS ${output_file})
+ foreach(source_file
+ ${CMAKE_CURRENT_SOURCE_DIR}/profile-templates/all/all/${file}
+ ${CMAKE_CURRENT_SOURCE_DIR}/profile-templates/all/${arch}/${file}
+ ${CMAKE_CURRENT_SOURCE_DIR}/profile-templates/${profile}/all/${file}
+ ${CMAKE_CURRENT_SOURCE_DIR}/profile-templates/${profile}/${arch}/${file})
+ if(EXISTS ${source_file})
+ file(READ ${source_file} content)
+ if(EXISTS ${source_file})
+ file(APPEND ${output_file} ${content})
+ else(EXISTS ${source_file})
+ file(WRITE ${output_file} ${content})
+ endif(EXISTS ${source_file})
+ endif(EXISTS ${source_file})
+ endforeach(source_file)
+ if(EXISTS ${output_file})
+ message(STATUS "Generated schroot profile ${profile}/${file}")
+ install(FILES ${output_file}
+ DESTINATION ${SCHROOT_SYSCONF_DIR}/${profile})
+ endif(EXISTS ${output_file})
+ endforeach(arch)
+ endforeach(file)
+endforeach(profile)
+
+add_subdirectory(pam)
+add_subdirectory(bash_completion)
+add_subdirectory(setup.d)