summaryrefslogtreecommitdiff
path: root/bin/schroot-mount/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bin/schroot-mount/Makefile.am')
-rw-r--r--bin/schroot-mount/Makefile.am22
1 files changed, 8 insertions, 14 deletions
diff --git a/bin/schroot-mount/Makefile.am b/bin/schroot-mount/Makefile.am
index 8d7fab18..b4860987 100644
--- a/bin/schroot-mount/Makefile.am
+++ b/bin/schroot-mount/Makefile.am
@@ -19,21 +19,15 @@
#
#####################################################################
-include $(top_srcdir)/scripts/global.mk
+pkglibexec_PROGRAMS += bin/schroot-mount/schroot-mount
-LOCAL_CXXFLAGS = $(SCHROOT_CFLAGS) -I$(top_srcdir)/bin
+bin_schroot_mount_schroot_mount_SOURCES = \
+ bin/schroot-mount/schroot-mount-main.h \
+ bin/schroot-mount/schroot-mount-main.cc \
+ bin/schroot-mount/schroot-mount-options.h \
+ bin/schroot-mount/schroot-mount-options.cc \
+ bin/schroot-mount/schroot-mount.cc
-LOCAL_DEFS = -DLOCALEDIR=\"$(localedir)\"
-
-pkglibexec_PROGRAMS = schroot-mount
-
-schroot_mount_SOURCES = \
- schroot-mount-main.h \
- schroot-mount-main.cc \
- schroot-mount-options.h \
- schroot-mount-options.cc \
- schroot-mount.cc
-
-schroot_mount_LDADD = $(BOOST_FILESYSTEM_LIBS) \
+bin_schroot_mount_schroot_mount_LDADD = $(BOOST_FILESYSTEM_LIBS) \
$(top_builddir)/bin/schroot-base/libschroot-base.la