summaryrefslogtreecommitdiff
path: root/bin/schroot/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bin/schroot/Makefile.am')
-rw-r--r--bin/schroot/Makefile.am58
1 files changed, 26 insertions, 32 deletions
diff --git a/bin/schroot/Makefile.am b/bin/schroot/Makefile.am
index 463e20ec..7ce59220 100644
--- a/bin/schroot/Makefile.am
+++ b/bin/schroot/Makefile.am
@@ -19,41 +19,35 @@
#
#####################################################################
-include $(top_srcdir)/scripts/global.mk
-
-localedir = $(datadir)/locale
-
-LOCAL_CXXFLAGS = $(SCHROOT_CFLAGS) -I$(top_srcdir)/bin
-
-LOCAL_DEFS = -DLOCALEDIR=\"$(localedir)\"
-
-noinst_LTLIBRARIES = libschroot.la libschroot-all.la
-
-bin_PROGRAMS = schroot
-
-libschroot_la_SOURCES = \
- schroot-options-base.h \
- schroot-options-base.cc \
- schroot-main-base.h \
- schroot-main-base.cc \
- schroot-main.h \
- schroot-main.cc
-libschroot_la_LIBADD = $(top_builddir)/bin/schroot-base/libschroot-base.la
-
-libschroot_all_la_SOURCES = \
- schroot-options.h \
- schroot-options.cc
-libschroot_all_la_LIBADD = libschroot.la
-
-schroot_SOURCES = \
- schroot.cc
-schroot_LDADD = libschroot-all.la
-
-install-exec-hook:
+noinst_LTLIBRARIES += \
+ bin/schroot/libschroot.la \
+ bin/schroot/libschroot-all.la
+
+bin_PROGRAMS += bin/schroot/schroot
+
+bin_schroot_libschroot_la_SOURCES = \
+ bin/schroot/schroot-options-base.h \
+ bin/schroot/schroot-options-base.cc \
+ bin/schroot/schroot-main-base.h \
+ bin/schroot/schroot-main-base.cc \
+ bin/schroot/schroot-main.h \
+ bin/schroot/schroot-main.cc
+bin_schroot_libschroot_la_LIBADD = $(top_builddir)/bin/schroot-base/libschroot-base.la
+
+bin_schroot_libschroot_all_la_SOURCES = \
+ bin/schroot/schroot-options.h \
+ bin/schroot/schroot-options.cc
+bin_schroot_libschroot_all_la_LIBADD = bin/schroot/libschroot.la
+
+bin_schroot_schroot_SOURCES = \
+ bin/schroot/schroot.cc
+bin_schroot_schroot_LDADD = bin/schroot/libschroot-all.la
+
+install-exec-hook::
# Install setuid root.
chmod 4755 "$(DESTDIR)$(bindir)/schroot"
-install-data-hook:
+install-data-hook::
$(MKDIR_P) $(DESTDIR)$(schroot_sysconf_chrootdir)
$(MKDIR_P) $(DESTDIR)$(schroot_mountdir)
$(MKDIR_P) $(DESTDIR)$(schroot_sessiondir)