summaryrefslogtreecommitdiff
path: root/lib/dchroot-common/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/dchroot-common/CMakeLists.txt')
-rw-r--r--lib/dchroot-common/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/lib/dchroot-common/CMakeLists.txt b/lib/dchroot-common/CMakeLists.txt
new file mode 100644
index 00000000..3cac2a43
--- /dev/null
+++ b/lib/dchroot-common/CMakeLists.txt
@@ -0,0 +1,27 @@
+# Copyright © 2004-2013 Roger Leigh <rleigh@debian.org>
+#
+# schroot is free software: you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# schroot is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see
+# <http://www.gnu.org/licenses/>.
+#
+#####################################################################
+
+set(dchroot_common_sources
+ main.h
+ main.cc
+ session.h
+ session.cc)
+
+if (BUILD_LIBDCHROOT)
+ add_library(dchroot-common STATIC ${dchroot_common_sources})
+endif (BUILD_LIBDCHROOT)