summaryrefslogtreecommitdiff
path: root/lib/test/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'lib/test/CMakeLists.txt')
-rw-r--r--lib/test/CMakeLists.txt25
1 files changed, 25 insertions, 0 deletions
diff --git a/lib/test/CMakeLists.txt b/lib/test/CMakeLists.txt
new file mode 100644
index 00000000..b8a5c17a
--- /dev/null
+++ b/lib/test/CMakeLists.txt
@@ -0,0 +1,25 @@
+# Copyright © 2004-2013 Roger Leigh <rleigh@debian.org>
+#
+# schroot is free software: you can redistribute it and/or modify it
+# under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# schroot is distributed in the hope that it will be useful, but
+# WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the GNU
+# General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see
+# <http://www.gnu.org/licenses/>.
+#
+#####################################################################
+
+set(test_sources
+ testmain.cc)
+
+if (BUILD_TESTS)
+ add_library(testmain STATIC ${test_sources})
+ target_link_libraries(testmain sbuild ${GTEST_LIBRARIES} ${CMAKE_THREAD_LIBS_INIT})
+endif (BUILD_TESTS)