summaryrefslogtreecommitdiff
path: root/3rd-party/zisofs_tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to '3rd-party/zisofs_tools/CMakeLists.txt')
-rw-r--r--3rd-party/zisofs_tools/CMakeLists.txt8
1 files changed, 8 insertions, 0 deletions
diff --git a/3rd-party/zisofs_tools/CMakeLists.txt b/3rd-party/zisofs_tools/CMakeLists.txt
new file mode 100644
index 0000000..75068bf
--- /dev/null
+++ b/3rd-party/zisofs_tools/CMakeLists.txt
@@ -0,0 +1,8 @@
+PROJECT (ZISOFSTOOLS C)
+ADD_DEFINITIONS(-Wall -W -Wpointer-arith -Wbad-function-cast -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wnested-externs -Winline -Wshadow -Wcast-align)
+AUX_SOURCE_DIRECTORY(. MKZ_SRCS)
+ADD_EXECUTABLE (mkzftree ${MKZ_SRCS})
+TARGET_LINK_LIBRARIES(mkzftree z)
+SET_TARGET_PROPERTIES(mkzftree PROPERTIES SKIP_BUILD_RPATH TRUE)
+INSTALL(TARGETS mkzftree DESTINATION bin)
+INSTALL(FILES mkzftree.1 DESTINATION share/man/man1)