summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2009-07-14 17:40:43 +0200
committerMichael Biebl <biebl@debian.org>2009-07-14 17:40:43 +0200
commitb4c56fb4b5f0c496b544080c5dd38d3cf93c10e8 (patch)
treea042dc877254104c83167421a65a61bf7492885c /Makefile.am
downloadconsolekit-b4c56fb4b5f0c496b544080c5dd38d3cf93c10e8.tar.gz
Imported Upstream version 0.2.1upstream/0.2.1
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am65
1 files changed, 65 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..95be344
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,65 @@
+# This file will be processed with automake-1.7 to create Makefile.in
+
+AUTOMAKE_OPTIONS = 1.7
+
+NULL =
+
+SUBDIRS = \
+ src \
+ tools \
+ data \
+ doc \
+ libck-connector \
+ pam-ck-connector \
+ $(NULL)
+
+EXTRA_DIST = \
+ COPYING \
+ AUTHORS \
+ INSTALL \
+ README \
+ HACKING \
+ NEWS \
+ ChangeLog \
+ $(NULL)
+
+DISTCLEANFILES = \
+ $(NULL)
+
+MAINTAINERCLEANFILES = \
+ *~ \
+ intltool-*.in \
+ compile \
+ configure \
+ INSTALL \
+ install-sh \
+ missing \
+ mkinstalldirs \
+ config.guess \
+ ltmain.sh \
+ config.sub \
+ depcomp \
+ Makefile.in \
+ config.h.* \
+ aclocal.m4 \
+ $(NULL)
+
+# Creating ChangeLog from git log (taken from cairo/Makefile.am):
+
+ChangeLog: $(srcdir)/ChangeLog
+
+$(srcdir)/ChangeLog:
+ @if test -d "$(srcdir)/.git"; then \
+ (cd "$(srcdir)" && \
+ ./missing --run git-log --stat) | fmt --split-only > $@.tmp \
+ && mv -f $@.tmp $@ \
+ || ($(RM) $@.tmp; \
+ echo Failed to generate ChangeLog, your ChangeLog may be outdated >&2; \
+ (test -f $@ || echo git-log is required to generate this file >> $@)); \
+ else \
+ test -f $@ || \
+ (echo A git checkout and git-log is required to generate ChangeLog >&2 && \
+ echo A git checkout and git-log is required to generate this file >> $@); \
+ fi
+
+.PHONY: ChangeLog $(srcdir)/ChangeLog