summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorMichael Biebl <biebl@debian.org>2010-09-20 02:35:29 +0200
committerMichael Biebl <biebl@debian.org>2010-09-20 02:35:29 +0200
commit3c6531b4348d77778c4fab15e5d8e842bd15e091 (patch)
treebb7bdb1e1d12fb990c31f5445acee7d901fb7d1b /configure.ac
parent6f64702386210741d62f3394e27b1b6695dde698 (diff)
downloadconsolekit-3c6531b4348d77778c4fab15e5d8e842bd15e091.tar.gz
Imported Upstream version 0.4.2upstream/0.4.2
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 11 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index d797241..17afab8 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,14 +1,14 @@
AC_PREREQ(2.59c)
AC_INIT([ConsoleKit],
- [0.4.1],
+ [0.4.2],
[https://bugs.freedesktop.org/enter_bug.cgi?product=ConsoleKit],
[ConsoleKit])
AC_CONFIG_SRCDIR([src/ck-manager.c])
AM_INIT_AUTOMAKE([1.9 no-dist-gzip dist-bzip2])
-
+m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
AM_MAINTAINER_MODE
# for O_NOFOLLOW support
@@ -391,6 +391,15 @@ AC_SUBST(CFLAGS)
AC_SUBST(CPPFLAGS)
AC_SUBST(LDFLAGS)
+# systemd
+
+AC_ARG_WITH([systemdsystemunitdir],
+ AS_HELP_STRING([--with-systemdsystemunitdir=DIR], [Directory for systemd service files]),
+ [],
+ [with_systemdsystemunitdir=$($PKG_CONFIG --variable=systemdsystemunitdir systemd)])
+AC_SUBST([systemdsystemunitdir], [$with_systemdsystemunitdir])
+AM_CONDITIONAL(HAVE_SYSTEMD, [test -n "$with_systemdsystemunitdir"])
+
# Files
AC_CONFIG_FILES([