summaryrefslogtreecommitdiff
path: root/data/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'data/Makefile.am')
-rw-r--r--data/Makefile.am5
1 files changed, 5 insertions, 0 deletions
diff --git a/data/Makefile.am b/data/Makefile.am
index c45f15b..248f7cd 100644
--- a/data/Makefile.am
+++ b/data/Makefile.am
@@ -47,14 +47,19 @@ install-data-hook:
$(DESTDIR)$(systemdsystemunitdir)/reboot.target.wants \
$(DESTDIR)$(systemdsystemunitdir)/kexec.target.wants
( cd $(DESTDIR)$(systemdsystemunitdir)/basic.target.wants && \
+ rm -f console-kit-log-system-start.service && \
$(LN_S) ../console-kit-log-system-start.service )
( cd $(DESTDIR)$(systemdsystemunitdir)/halt.target.wants && \
+ rm -f console-kit-log-system-stop.service && \
$(LN_S) ../console-kit-log-system-stop.service )
( cd $(DESTDIR)$(systemdsystemunitdir)/poweroff.target.wants && \
+ rm -f console-kit-log-system-stop.service && \
$(LN_S) ../console-kit-log-system-stop.service )
( cd $(DESTDIR)$(systemdsystemunitdir)/reboot.target.wants && \
+ rm -f console-kit-log-system-restart.service && \
$(LN_S) ../console-kit-log-system-restart.service )
( cd $(DESTDIR)$(systemdsystemunitdir)/kexec.target.wants && \
+ rm -f console-kit-log-system-restart.service && \
$(LN_S) ../console-kit-log-system-restart.service )
endif