summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog1
-rw-r--r--debian/consolekit.install8
-rwxr-xr-xdebian/rules3
3 files changed, 11 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index cd95fb1..d4f935b 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -22,6 +22,7 @@ consolekit (0.4.3-1) UNRELEASED; urgency=low
- Convert debian/rules to use dh.
* debian/libck-connector-dev.install
- Install D-Bus interfaces files.
+ * Install systemd unit files.
-- Michael Biebl <biebl@debian.org> Wed, 17 Nov 2010 06:51:57 +0100
diff --git a/debian/consolekit.install b/debian/consolekit.install
index 0aefea5..8386ffc 100644
--- a/debian/consolekit.install
+++ b/debian/consolekit.install
@@ -7,3 +7,11 @@ debian/tmp/var/log/ConsoleKit/
debian/tmp/usr/sbin/
debian/tmp/usr/bin/
debian/90consolekit etc/X11/Xsession.d/
+debian/tmp/lib/systemd/system/console-kit-daemon.service
+debian/tmp/lib/systemd/system/console-kit-log-system-start.service
+debian/tmp/lib/systemd/system/console-kit-log-system-stop.service
+debian/tmp/lib/systemd/system/console-kit-log-system-restart.service
+debian/tmp/lib/systemd/system/basic.target.wants/console-kit-log-system-start.service
+debian/tmp/lib/systemd/system/halt.target.wants/console-kit-log-system-stop.service
+debian/tmp/lib/systemd/system/poweroff.target.wants/console-kit-log-system-stop.service
+debian/tmp/lib/systemd/system/reboot.target.wants/console-kit-log-system-restart.service
diff --git a/debian/rules b/debian/rules
index 94a814f..3a4c677 100755
--- a/debian/rules
+++ b/debian/rules
@@ -8,7 +8,8 @@ override_dh_auto_configure:
--libexecdir="\$$(prefix)/lib/ConsoleKit" \
--enable-pam-module \
--enable-docbook-docs \
- --with-pid-file=/var/run/console-kit-daemon.pid
+ --with-pid-file=/var/run/console-kit-daemon.pid \
+ --with-systemdsystemunitdir=/lib/systemd/system
override_dh_auto_install:
dh_auto_install