summaryrefslogtreecommitdiff
path: root/cmake/CMakeLists.txt
diff options
context:
space:
mode:
authorRalf Habacker <ralf.habacker@freenet.de>2011-07-03 00:54:20 +0200
committerRalf Habacker <ralf.habacker@freenet.de>2011-09-22 20:27:58 +0200
commit2f3403c37b7076297dcb8c0e1e803eab7723bf6b (patch)
tree8757f563a04aa294ac31529dc49b125f82a135bc /cmake/CMakeLists.txt
parentb49e27866741238223f0b62d9ed5fe1e68eff336 (diff)
downloaddbus-2f3403c37b7076297dcb8c0e1e803eab7723bf6b.tar.gz
Limit batch file creating to windows
cherry-picked 84b03cae585274bfe54e2a234dff72469cef581d
Diffstat (limited to 'cmake/CMakeLists.txt')
-rw-r--r--cmake/CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/cmake/CMakeLists.txt b/cmake/CMakeLists.txt
index 54a10e62..62f2e2a2 100644
--- a/cmake/CMakeLists.txt
+++ b/cmake/CMakeLists.txt
@@ -503,8 +503,12 @@ set (DBUS_INTERNAL_LIBRARY_DEFINITIONS "-DDBUS_STATIC_BUILD")
set (DBUS_INTERNAL_CLIENT_DEFINITIONS "-DDBUS_STATIC_BUILD")
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/config.h.cmake ${CMAKE_CURRENT_BINARY_DIR}/config.h )
+
+if (WIN32)
configure_file(${CMAKE_CURRENT_SOURCE_DIR}/dbus-env.bat.cmake ${CMAKE_BINARY_DIR}/bin/dbus-env.bat )
install_files(/bin FILES ${CMAKE_BINARY_DIR}/bin/dbus-env.bat)
+endif()
+
add_definitions(-DHAVE_CONFIG_H=1)
########### subdirs ###############