summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChengwei Yang <chengwei.yang@intel.com>2013-06-28 16:06:41 +0800
committerSimon McVittie <simon.mcvittie@collabora.co.uk>2013-06-28 12:17:15 +0100
commit134701b758d834eda139843fcb90c144b57a08b0 (patch)
tree6ab4bda355b391d04fbc1c129a094bc4776f4d3c /configure.ac
parent4df8738794422c216b25e1bc1bbc80654c948c5d (diff)
downloaddbus-134701b758d834eda139843fcb90c144b57a08b0.tar.gz
tests to embedded tests: replaced in automake files
Signed-off-by: Chengwei Yang <chengwei.yang@intel.com> Reviewed-by: Simon McVittie <simon.mcvittie@collabora.co.uk> Bug: https://bugs.freedesktop.org/show_bug.cgi?id=66291
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac6
1 files changed, 1 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 755e4f04..c80fcfcb 100644
--- a/configure.ac
+++ b/configure.ac
@@ -192,16 +192,12 @@ AC_ARG_ENABLE([tests],
[])
# DBUS_ENABLE_EMBEDDED_TESTS controls unit tests built in to .c files
-# and also some stuff in the test/ subdir. DBUS_BUILD_TESTS was an older
-# name for this.
-AM_CONDITIONAL([DBUS_BUILD_TESTS], [test "x$enable_embedded_tests" = xyes])
+# and also some stuff in the test/ subdir.
AM_CONDITIONAL([DBUS_ENABLE_EMBEDDED_TESTS],
[test "x$enable_embedded_tests" = xyes])
if test "x$enable_embedded_tests" = xyes; then
AC_DEFINE([DBUS_ENABLE_EMBEDDED_TESTS], [1],
[Define to build test code into the library and binaries])
- AC_DEFINE([DBUS_BUILD_TESTS], [1],
- [Define to build test code into the library and binaries])
fi
# DBUS_ENABLE_MODULAR_TESTS controls tests that work based on public API.