summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorSimon McVittie <smcv@debian.org>2011-02-17 20:11:50 +0000
committerSimon McVittie <smcv@debian.org>2011-02-17 20:11:50 +0000
commit973bf6901ad57657fea529e49073bcd251435719 (patch)
tree8c72c626b346820ca0223f2bff9567b40d08b926 /configure.in
parent280851b7fdb7050e42403f57cbbbdbc368e59efa (diff)
downloaddbus-973bf6901ad57657fea529e49073bcd251435719.tar.gz
Imported Upstream version 1.4.6upstream/1.4.6
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 1 insertions, 15 deletions
diff --git a/configure.in b/configure.in
index bf2c06e0..fde2a1bf 100644
--- a/configure.in
+++ b/configure.in
@@ -3,7 +3,7 @@ AC_PREREQ(2.52)
m4_define([dbus_major_version], [1])
m4_define([dbus_minor_version], [4])
-m4_define([dbus_micro_version], [4])
+m4_define([dbus_micro_version], [6])
m4_define([dbus_version],
[dbus_major_version.dbus_minor_version.dbus_micro_version])
AC_INIT(dbus, [dbus_version])
@@ -154,25 +154,11 @@ AC_ARG_WITH(dbus_daemondir, AS_HELP_STRING([--with-dbus-daemondir=[dirname]],[Di
dnl DBUS_BUILD_TESTS controls unit tests built in to .c files
dnl and also some stuff in the test/ subdir
-dnl
-dnl In principle we could have separate switches for the embedded
-dnl test code in the libraries (which cause bloat and possible security holes)
-dnl and the standalone GLib regression tests, but not right now.
AM_CONDITIONAL(DBUS_BUILD_TESTS, test x$enable_tests = xyes)
if test x$enable_tests = xyes; then
AC_DEFINE(DBUS_BUILD_TESTS,1,[Build test code])
fi
-AC_ARG_ENABLE([standalone-tests],
- AS_HELP_STRING([--enable-standalone-tests],
- [enable standalone regression tests (GLib 2.16 required)]),
- [], [enable_standalone_tests=yes])
-
-if test x$enable_standalone_tests = xyes; then
- PKG_CHECK_MODULES([GLIB], [glib-2.0 >= 2.16],
- [], [AC_MSG_ERROR([The standalone regression tests require GLib])])
-fi
-
if test x$enable_verbose_mode = xyes; then
AC_DEFINE(DBUS_ENABLE_VERBOSE_MODE,1,[Support a verbose mode])
fi