summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am59
1 files changed, 59 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 00000000..ac31a7fc
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,59 @@
+SUBDIRS=dbus bus doc tools test
+DIST_SUBDIRS=dbus bus doc tools test
+
+pkgconfigdir = $(libdir)/pkgconfig
+pkgconfig_DATA = dbus-1.pc
+
+DISTCLEANFILES = \
+ dbus-1.pc
+
+EXTRA_DIST = \
+ HACKING \
+ dbus-1.pc.in \
+ cleanup-man-pages.sh \
+ ChangeLog.pre-1-0 \
+ NEWS.pre-1-0 \
+ ChangeLog.pre-1-2 \
+ NEWS.pre-1-2
+
+all-local: Doxyfile
+
+if DBUS_GCOV_ENABLED
+clean-gcov:
+ find -name "*.da" -o -name "*.gcov" | xargs rm || true
+
+clean-bbg:
+ find -name "*.bbg" -o -name "*.bb" | xargs rm || true
+
+GCOV_DIRS=dbus bus
+
+## .PHONY so it always rebuilds it
+.PHONY: coverage-report.txt
+coverage-report.txt:
+ BBG_FILES=`find $(GCOV_DIRS) -name "*.bbg" -o -name "*.gcno"` ; \
+ C_FILES= ; \
+ for F in $$BBG_FILES ; do \
+ F_nolibs=`echo $$F | sed -e 's/.libs\///g'` ; \
+ C=`echo $$F_nolibs | sed -e 's/.bbg/.c/g' | sed -e 's/.gcno/.c/g'` ; \
+ B=`basename $$F .bbg` ; \
+ D=`dirname $$F` ; \
+ DA=`echo $$F | sed -e 's/.bbg/.da/g'` ; \
+ DA_libs=`echo $$D/.libs/$$B/.da` ; \
+ if test -e $$DA || test -e $$DA_libs; then \
+ C_FILES="$$C_FILES $$C" ; \
+ fi ; \
+ done ; \
+ echo $$C_FILES ; \
+ $(top_builddir)/test/decode-gcov --report $$C_FILES > coverage-report.txt
+
+check-coverage: clean-gcov all check coverage-report.txt
+ cat coverage-report.txt
+
+else
+coverage-report.txt:
+ echo "Need to reconfigure with --enable-gcov"
+
+check-coverage:
+ echo "Need to reconfigure with --enable-gcov"
+
+endif