summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 8 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 7fca39a1..4f57d924 100755
--- a/debian/rules
+++ b/debian/rules
@@ -11,8 +11,14 @@ libdbusN := $(shell sed -rn 's/Package:[[:space:]]*(libdbus-[0-9-]+)[[:space:]]*
multiarch := $(shell dpkg-architecture -qDEB_HOST_MULTIARCH)
cflags := $(shell dpkg-buildflags --get CFLAGS)
-ldflags := $(shell dpkg-buildflags --get LDFLAGS) -Wl,--as-needed
-common_configure_flags = \
+ldflags := $(shell dpkg-buildflags --get LDFLAGS)
+ldflags += -Wl,--as-needed
+
+include /usr/share/hardening-includes/hardening.make
+cflags += $(HARDENING_CFLAGS)
+ldflags += $(HARDENING_LDFLAGS)
+
+common_configure_flags := \
--disable-libaudit \
--libexecdir=\$${prefix}/lib/dbus-1.0 \
--htmldir=\$${prefix}/share/doc/dbus \