summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog15
-rw-r--r--debian/control1
-rw-r--r--debian/dbus-1-doc.install5
-rw-r--r--debian/dbus-1-doc.links1
-rw-r--r--debian/doxygen_to_devhelp.xsl40
-rw-r--r--debian/patches/dbus-1.0.1-generate-xml-docs.patch11
-rwxr-xr-xdebian/rules2
7 files changed, 74 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index 84003539..b25dd924 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,18 @@
+dbus (1.1.2-2) UNRELEASED; urgency=low
+
+ * Merge patch from Ubuntu to build a devhelp file; thanks Martin Pitt;
+ closes: #454142.
+ - Build-dep on xsltproc.
+ - New patch, dbus-1.0.1-generate-xml-docs, enables generation of XML docs
+ which serve as source for the devhelp generation.
+ - Add a XSLT file from the Fedora package, debian/doxygen_to_devhelp.xsl.
+ - Generate the devhelp file from the XML files thanks to the XSL file via
+ xsltproc in build/dbus-1-doc::.
+ - Install the devhelp index in dbus-1-doc and move the HTML documentation
+ around; add a symlink from the gtk-doc dir.
+
+ -- Loic Minier <lool@dooz.org> Mon, 03 Dec 2007 15:42:01 +0100
+
dbus (1.1.2-1) unstable; urgency=low
[ Michael Biebl ]
diff --git a/debian/control b/debian/control
index d3956fa5..1508629c 100644
--- a/debian/control
+++ b/debian/control
@@ -13,6 +13,7 @@ Build-Depends: cdbs (>= 0.4.43),
doxygen,
docbook-utils,
xmlto,
+ xsltproc,
libx11-dev,
libselinux1-dev [!hurd-i386 !kfreebsd-i386 !kfreebsd-amd64]
Standards-Version: 3.7.2
diff --git a/debian/dbus-1-doc.install b/debian/dbus-1-doc.install
index 56075c63..68707b7d 100644
--- a/debian/dbus-1-doc.install
+++ b/debian/dbus-1-doc.install
@@ -1,4 +1,7 @@
doc/dbus-specification.html usr/share/doc/dbus-1-doc
doc/dbus-test-plan.html usr/share/doc/dbus-1-doc
doc/dcop-howto.txt usr/share/doc/dbus-1-doc
-doc/api/html usr/share/doc/dbus-1-doc/api/
+doc/api/html/* usr/share/doc/dbus-1-doc/html/api
+dbus.devhelp usr/share/doc/dbus-1-doc/html
+doc/dbus-{faq,specification,tutorial}.html usr/share/doc/dbus-1-doc/html
+
diff --git a/debian/dbus-1-doc.links b/debian/dbus-1-doc.links
new file mode 100644
index 00000000..8197708d
--- /dev/null
+++ b/debian/dbus-1-doc.links
@@ -0,0 +1 @@
+usr/share/doc/dbus-1-doc/html usr/share/gtk-doc/html/dbus
diff --git a/debian/doxygen_to_devhelp.xsl b/debian/doxygen_to_devhelp.xsl
new file mode 100644
index 00000000..72098f9f
--- /dev/null
+++ b/debian/doxygen_to_devhelp.xsl
@@ -0,0 +1,40 @@
+<xsl:stylesheet
+ xmlns:xsl="http://www.w3.org/1999/XSL/Transform"
+ xmlns:fo="http://www.w3.org/1999/XSL/Format"
+ version="1.0">
+
+<xsl:output method="xml" version="1.0" indent="yes"/>
+
+<xsl:param name="prefix"></xsl:param>
+
+<xsl:template match="/">
+ <book title="D-Bus: A system for interprocess communication"
+ name="dbus"
+ link="dbus-tutorial.html">
+ <chapters>
+ <sub name="Tutorial" link="{$prefix}dbus-tutorial.html"/>
+ <sub name="FAQ" link="{$prefix}dbus-faq.html"/>
+ <sub name="Specification" link="{$prefix}dbus-specification.html"/>
+ <sub name="API Reference" link="{$prefix}api/index.html"/>
+ </chapters>
+
+ <functions>
+ <xsl:apply-templates select="doxygenindex/compound[@kind='group']/member[@kind='function']"/>
+ </functions>
+ </book>
+</xsl:template>
+
+<xsl:template match="member">
+ <xsl:param name="name"><xsl:value-of select="name"/></xsl:param>
+ <xsl:param name="refid"><xsl:value-of select="@refid"/></xsl:param>
+ <xsl:param name="before"><xsl:value-of select="substring-before($refid,'_1')"/></xsl:param>
+ <xsl:param name="after"><xsl:value-of select="substring-after($refid,'_1')"/></xsl:param>
+ <xsl:param name="link"><xsl:value-of select="$before"/>.html#<xsl:value-of select="$after"/></xsl:param>
+ <xsl:if test="starts-with($name,'dbus') or starts-with($name, 'DBus')">
+ <xsl:if test="starts-with($refid,'group__') and contains($refid, '_1')">
+ <function name="{$name}" link="{$prefix}api/{$link}"/>
+ </xsl:if>
+ </xsl:if>
+</xsl:template>
+
+</xsl:stylesheet>
diff --git a/debian/patches/dbus-1.0.1-generate-xml-docs.patch b/debian/patches/dbus-1.0.1-generate-xml-docs.patch
new file mode 100644
index 00000000..60598bc5
--- /dev/null
+++ b/debian/patches/dbus-1.0.1-generate-xml-docs.patch
@@ -0,0 +1,11 @@
+--- dbus-1.0.1/Doxyfile.in.generate-xml-docs 2006-11-25 23:42:59.000000000 -0500
++++ dbus-1.0.1/Doxyfile.in 2006-11-25 23:43:12.000000000 -0500
+@@ -133,7 +133,7 @@
+ #---------------------------------------------------------------------------
+ # configuration options related to the XML output
+ #---------------------------------------------------------------------------
+-GENERATE_XML = NO
++GENERATE_XML = YES
+ #---------------------------------------------------------------------------
+ # Configuration options related to the preprocessor
+ #---------------------------------------------------------------------------
diff --git a/debian/rules b/debian/rules
index 7dccc220..b44dadff 100755
--- a/debian/rules
+++ b/debian/rules
@@ -24,9 +24,11 @@ binary-post-install/dbus-x11::
build/dbus-1-doc::
doxygen Doxyfile
+ xsltproc -o dbus.devhelp debian/doxygen_to_devhelp.xsl doc/api/xml/index.xml
clean::
rm -rf doc/api
rm -f test/data/valid-config-files/session.conf
rm -f test/data/valid-config-files/system.conf
rm -f doc/*.html
+ rm -f dbus.devhelp