summaryrefslogtreecommitdiff
path: root/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'doc/Makefile.am')
-rw-r--r--doc/Makefile.am41
1 files changed, 41 insertions, 0 deletions
diff --git a/doc/Makefile.am b/doc/Makefile.am
new file mode 100644
index 00000000..f76335f6
--- /dev/null
+++ b/doc/Makefile.am
@@ -0,0 +1,41 @@
+EXTRA_DIST= \
+ busconfig.dtd \
+ diagram.png \
+ diagram.svg \
+ introspect.dtd \
+ dbus-faq.xml \
+ dbus-specification.xml \
+ dbus-test-plan.xml \
+ dbus-tutorial.xml \
+ dcop-howto.txt \
+ file-boilerplate.c \
+ introspect.xsl \
+ system-activation.txt
+
+HTML_FILES= \
+ dbus-faq.html \
+ dbus-specification.html \
+ dbus-test-plan.html \
+ dbus-tutorial.html
+
+if DBUS_XML_DOCS_ENABLED
+all-local: $(HTML_FILES)
+
+EXTRA_DIST += $(HTML_FILES)
+
+dbus-specification.html: dbus-specification.xml
+ $(XMLTO) html-nochunks $<
+
+dbus-test-plan.html: dbus-test-plan.xml
+ $(XMLTO) html-nochunks $<
+
+dbus-tutorial.html: dbus-tutorial.xml
+ $(XMLTO) html-nochunks $<
+
+dbus-faq.html: dbus-faq.xml
+ $(XMLTO) html-nochunks $<
+
+endif
+
+maintainer-clean-local:
+ rm -f $(HTML_FILES)