summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorSven Joachim <svenjoac@gmx.de>2019-08-15 19:24:27 +0200
committerSven Joachim <svenjoac@gmx.de>2019-09-01 13:25:14 +0200
commitfb2428df41d0c65c8357d6e0dd0ae679d467c994 (patch)
treec1de42702cedeeb1a9c8d5e02d01319fda7565f8 /debian/rules
parent5473d86bf0b65c4624a32d784baec4e51c1a6f2a (diff)
downloaddebhelper-fb2428df41d0c65c8357d6e0dd0ae679d467c994.tar.gz
Split off a libdebhelper-perl binary package
This makes it possible for debhelper adddon packages to depend on it rather than on debhelper, breaking the circular dependencies between debhelper and dh-autoreconf/dh-strip-nondeterminism. The autoscripts are used by the autoscript routine in Dh_Lib.pm, so I decided to put those into libdebhelper-perl as well. Closes: #821130
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules4
1 files changed, 2 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 756fe9c0..57454cd1 100755
--- a/debian/rules
+++ b/debian/rules
@@ -18,7 +18,7 @@ PERL ?= perl
# builds without needing autotools-dev, dh-strip-nondetermism etc.)
override_dh_update_autotools_config override_dh_strip_nondeterminism:
-override_dh_auto_install:
- ./run dh_auto_install --destdir=debian/debhelper
+override_dh_install:
+ ./run dh_install
PERLLIBDIR=$$($(PERL) -MConfig -e 'print $$Config{vendorlib}')/Debian/Debhelper ; \
$(PERL) -I"debian/debhelper/$${PERLLIBDIR}" debian/gen-provides > debian/debhelper.substvars