summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClint Adams <clint@debian.org>2012-03-27 15:29:04 -0400
committerClint Adams <clint@debian.org>2012-03-27 15:29:04 -0400
commit4549a0b0b6c8033c41199720dee1ddb953497a9d (patch)
treea1a897f9f52b944dc45fa4dc3ce6a564fed36f90
parent72bc403e1dbb2f1852b290523aafe70342755912 (diff)
downloaddebianutils-4549a0b0b6c8033c41199720dee1ddb953497a9d.tar.gz
Patch from Wookey to fix stripping on cross-builds. closes: #665988.
-rwxr-xr-xdebian/rules8
1 files changed, 6 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 778e524..6256fd2 100755
--- a/debian/rules
+++ b/debian/rules
@@ -12,8 +12,12 @@ INSTALL_DIR = $(INSTALL) -p -d -o root -g root -m 755
DEB_BUILD_ARCH_OS ?= $(shell dpkg-architecture -qDEB_BUILD_ARCH_OS)
DEB_BUILD_GNU_TYPE = $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
DEB_HOST_GNU_TYPE = $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+
+STRIP=strip
+
ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
-CONFARGS = --host=$(DEB_HOST_GNU_TYPE)
+CONFARGS = --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
+STRIP=$(DEB_HOST_GNU_TYPE)-strip
endif
CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
@@ -63,7 +67,7 @@ binary-arch: checkroot build
debian/tmp/bin/
ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
- strip --remove-section=.comment --remove-section=.note \
+ $(STRIP) --remove-section=.comment --remove-section=.note \
debian/tmp/bin/run-parts \
debian/tmp/bin/tempfile \
debian/tmp/usr/bin/ischroot