summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClint Adams <clint@debian.org>2011-10-08 21:26:22 -0400
committerClint Adams <clint@debian.org>2011-12-01 19:44:14 -0500
commit543ac3b0716991f60bbcf8aa554fb32d1c807dce (patch)
tree0e06097c432a6c6b2bad7ae0b023a65f41dfc4b7
parentbece51938fa91d24d0bd5d76ce07733450b89be8 (diff)
downloaddebianutils-543ac3b0716991f60bbcf8aa554fb32d1c807dce.tar.gz
Use dpkg-buildflags
-rwxr-xr-xdebian/rules18
1 files changed, 8 insertions, 10 deletions
diff --git a/debian/rules b/debian/rules
index df5ff65..778e524 100755
--- a/debian/rules
+++ b/debian/rules
@@ -16,22 +16,20 @@ ifneq ($(DEB_BUILD_GNU_TYPE),$(DEB_HOST_GNU_TYPE))
CONFARGS = --host=$(DEB_HOST_GNU_TYPE)
endif
-ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
-CFLAGS += -O0
-else
-CFLAGS += -O2
-endif
-#ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
-#INSTALL_PROGRAM += -s
-#endif
+CFLAGS := $(shell dpkg-buildflags --get CFLAGS)
+CPPFLAGS := $(shell dpkg-buildflags --get CPPFLAGS)
+LDFLAGS := $(shell dpkg-buildflags --get LDFLAGS)
build: build-indep build-arch
build-indep:
build-arch:
$(checkdir)
- CFLAGS="$(CFLAGS)" ./configure --prefix=/usr \
- --mandir=/usr/share/man $(CONFARGS)
+ ./configure CFLAGS="$(CFLAGS)" \
+ CPPFLAGS="$(CPPFLAGS)" \
+ LDFLAGS="$(LDFLAGS)" \
+ --prefix=/usr \
+ --mandir=/usr/share/man $(CONFARGS)
$(MAKE)
touch build-arch