summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClint Adams <schizo@debian.org>2007-12-04 18:26:54 -0500
committerClint Adams <schizo@debian.org>2007-12-04 18:26:54 -0500
commit59b208e37efaee4a5f256cfe0bf9bd0a9bf48324 (patch)
treea73d2944b16ee2bb1b298f8bc43fefcbfb73bd0f
parentbea1ef5adc28e5233eaaf86fdecd5e1a88142757 (diff)
downloaddebianutils-59b208e37efaee4a5f256cfe0bf9bd0a9bf48324.tar.gz
* which: make case statement more concise as per suggestion of
Adam Katz. closes: #453345.
-rw-r--r--debian/changelog7
-rw-r--r--which3
2 files changed, 8 insertions, 2 deletions
diff --git a/debian/changelog b/debian/changelog
index fbd3081..b61c400 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,10 @@
+debianutils (2.28.1) unstable; urgency=low
+
+ * which: make case statement more concise as per suggestion of
+ Adam Katz. closes: #453345.
+
+ -- Clint Adams <schizo@debian.org> Tue, 04 Dec 2007 18:24:07 -0500
+
debianutils (2.28) unstable; urgency=low
* Apply patch from Martin Krafft to add -x option to savelog.
diff --git a/which b/which
index 6fd19ae..894f0bd 100644
--- a/which
+++ b/which
@@ -28,8 +28,7 @@ else
ALLRET=0
fi
case $PATH in
- *::) : "not *DIR:" ;;
- *:) PATH="$PATH:" ;;
+ (*[^:]:) PATH="$PATH:" ;;
esac
for PROGRAM in "$@"; do
RET=1