summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorClint Adams <schizo@debian.org>2007-12-05 16:33:06 -0500
committerClint Adams <schizo@debian.org>2007-12-05 16:33:06 -0500
commit98c48c04a4d676b6e06477986754befefd2ec3d2 (patch)
tree3f0e9312acf31081aa7f5b06f8bf3995458824fe
parentfb0ba6af0a01ecdd5acd755467d50b9b3d728050 (diff)
downloaddebianutils-98c48c04a4d676b6e06477986754befefd2ec3d2.tar.gz
which: fix bracket expression for matching. closes: #453345.
-rw-r--r--debian/changelog6
-rw-r--r--which2
2 files changed, 7 insertions, 1 deletions
diff --git a/debian/changelog b/debian/changelog
index b61c400..bfd7ce3 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,9 @@
+debianutils (2.28.2) unstable; urgency=high
+
+ * which: fix bracket expression for matching. closes: #453345.
+
+ -- Clint Adams <schizo@debian.org> Wed, 05 Dec 2007 16:31:48 -0500
+
debianutils (2.28.1) unstable; urgency=low
* which: make case statement more concise as per suggestion of
diff --git a/which b/which
index 894f0bd..5b2329d 100644
--- a/which
+++ b/which
@@ -28,7 +28,7 @@ else
ALLRET=0
fi
case $PATH in
- (*[^:]:) PATH="$PATH:" ;;
+ (*[!:]:) PATH="$PATH:" ;;
esac
for PROGRAM in "$@"; do
RET=1