summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorClint Adams <clint@debian.org>2011-05-18 15:03:14 -0400
committerClint Adams <clint@debian.org>2011-05-18 15:12:57 -0400
commit23aa3ababf5b35deb09145caa82ddfffe3228183 (patch)
treea2ef7fde1db93a6ff21fdedd30bd537b43182ede /debian
parente8fae4623f2fc84c5d0c31315d54bc3a7f7fdf63 (diff)
downloaddebianutils-23aa3ababf5b35deb09145caa82ddfffe3228183.tar.gz
ischroot utility by Aurelien Jarno. closes: #627205.
Diffstat (limited to 'debian')
-rwxr-xr-xdebian/rules7
1 files changed, 5 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index dd44f41..e1d4e49 100755
--- a/debian/rules
+++ b/debian/rules
@@ -64,7 +64,8 @@ binary-arch: checkroot build
ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
strip --remove-section=.comment --remove-section=.note \
debian/tmp/bin/run-parts \
- debian/tmp/bin/tempfile
+ debian/tmp/bin/tempfile \
+ debian/tmp/usr/bin/ischroot
endif
ifneq ($(DEB_HOST_ARCH_OS),hurd)
@@ -91,7 +92,9 @@ endif
cd debian/tmp && find * -type f ! -regex '^DEBIAN/.*' -print0 | xargs -r0 md5sum > DEBIAN/md5sums
- dpkg-shlibdeps debian/tmp/bin/run-parts debian/tmp/bin/tempfile
+ dpkg-shlibdeps debian/tmp/bin/run-parts \
+ debian/tmp/bin/tempfile \
+ debian/tmp/usr/bin/ischroot
dpkg-gencontrol -isp
dpkg --build debian/tmp ..