summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2010-05-26 02:37:42 +0200
committerGuillem Jover <guillem@debian.org>2010-05-26 02:51:28 +0200
commite844672595246c81f4a8e45ca842dc6aa3a4dbc8 (patch)
treeffbef18e22bd0241b148fd9bad87c8264ed96180 /configure.ac
parente1ce8e5e0027333a0f3071b9d8bd81b53cbb1011 (diff)
downloaddpkg-e844672595246c81f4a8e45ca842dc6aa3a4dbc8.tar.gz
build: Only use mmap in parser if explicitly requested
The current mmap code is not reliable, as it does not handle SIGBUS, which can happen on I/O errors (among others). Switch the code to check for USE_MMAP instead of HAVE_MMAP so that it can be explicitly enabled on build, to produce consistent results by making sure it does not get reactivated accidentally. Disable it by default due to the above, in addition to not having been used by released tarballs since 1.14.15.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6e8c6b9bb..bf9a7b4ef 100644
--- a/configure.ac
+++ b/configure.ac
@@ -127,6 +127,8 @@ DPKG_CHECK_COMPAT_FUNCS([getopt getopt_long obstack_free \
AC_CHECK_FUNCS([strtoul isascii bcopy memcpy lchown setsid getdtablesize \
posix_fadvise])
+DPKG_MMAP
+
AC_DEFINE(LIBDPKG_VOLATILE_API, 1, [Acknowledge the volatility of the API.])
DPKG_COMPILER_WARNINGS
DPKG_COMPILER_OPTIMISATIONS