summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorAdam Heath <doogie@debian.org>2001-05-01 05:35:00 +0000
committerAdam Heath <doogie@debian.org>2001-05-01 05:35:00 +0000
commitc6485f04533cd58f39420d4ebca5adc63dc0af21 (patch)
tree003d5929a4a813432e851733e8693b43c0258e83 /configure.in
parent0e2064f205778dfc09513aed8ef0c7f8f73e8f7c (diff)
downloaddpkg-c6485f04533cd58f39420d4ebca5adc63dc0af21.tar.gz
Check for __va_copy, and use it, instead of a direct assignment, for broken
arches, like ppc.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in16
1 files changed, 16 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index cd64f54fa..2e189ea99 100644
--- a/configure.in
+++ b/configure.in
@@ -169,6 +169,22 @@ AC_TRY_COMPILE([
AC_TRY_COMPILE(,[
} inline int foo (int x) {], AC_DEFINE(HAVE_INLINE))
+AC_MSG_CHECKING([for __va_copy])
+AC_TRY_COMPILE([
+#include <stdarg.h>
+],[
+va_list v1,v2;
+__va_copy(v1, v2);
+], [AC_MSG_RESULT(yes)
+AC_DEFINE(HAVE_VA_COPY)],[AC_MSG_RESULT(no)
+AC_MSG_CHECKING([for va_list assignment copy])
+AC_TRY_COMPILE([
+#include <stdarg.h>
+],[
+va_list v1,v2;
+v1 = v2;
+], AC_MSG_RESULT(yes),AC_MSG_ERROR(no))])
+
DPKG_CACHED_TRY_COMPILE(__attribute__((,,)),dpkg_cv_c_attribute_supported,,
[extern int testfunction(int x) __attribute__((,,))],
AC_MSG_RESULT(yes)