summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorWichert Akkerman <wakkerma@debian.org>1999-12-16 23:43:40 +0000
committerWichert Akkerman <wakkerma@debian.org>1999-12-16 23:43:40 +0000
commitda7f9947d8b8bf8a934febd5240c25860f042ae2 (patch)
tree78e02cbf4ff8a12478db76350a4174ba266fcb2f /configure.in
parentdc410dca4cb9409214f83393221854d61d780a90 (diff)
downloaddpkg-da7f9947d8b8bf8a934febd5240c25860f042ae2.tar.gz
Makefile.conf.in: use @libdir@ and @admindir@
configure.in: add --with-admindir option and change the default to $libdir/db debian/rules: add --with-admindir=/var/lib/dpkg scripts/debian-changelog-mode.el: update location of GPL scripts/dpkg-name.sh: update location of GPL
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in13
1 files changed, 13 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index ab00fcdf8..57a337f6a 100644
--- a/configure.in
+++ b/configure.in
@@ -15,6 +15,19 @@ AC_ARG_WITH(dselect,
esac])
AC_SUBST(DSELECTDIR)
+admindir="$libdir/db"
+AC_ARG_WITH(admindir,
+[ --with-admindir=DIR store dpkg database in DIR [LIBDIR/db]],
+[case "$withval" in
+ "" )
+ AC_MSG_ERROR(invalid admindir specified)
+ ;;
+ * )
+ admindir="$withval"
+ ;;
+ esac])
+AC_SUBST(admindir)
+
AC_CHECK_TOOL_PREFIX
AC_CANONICAL_SYSTEM