summaryrefslogtreecommitdiff
path: root/debian.buildscript
diff options
context:
space:
mode:
authorIan Jackson <ian@chiark.chu.cam.ac.uk>1996-05-16 00:01:21 +0100
committerIan Jackson <ian@chiark.chu.cam.ac.uk>1996-05-16 00:01:21 +0100
commitd4d3484ac88ca3953fef3cf2c0464cdc776b6574 (patch)
treeab15ab1e585e5c1d97b44f7b880af96632b1f08c /debian.buildscript
parent258ed6ae6ff639a76b534353fcc502d4ca97ca8c (diff)
downloaddpkg-d4d3484ac88ca3953fef3cf2c0464cdc776b6574.tar.gz
dpkg (1.2.0); priority=MEDIUM
* dselect can sort packages by available and installed states, and display their version numbers. (Use O, o and V.) * Hold is properly integrated as a real `wanted state', rather than a separate flag. * Epochs in version numbers implemented, using the syntax <epoch>:<version>-<revision>. (Epoch not usually displayed.) * dselect disk method is architecture-independent (uses dpkg's installation architecture, and looks in the right part of the tree). * dselect disk method doesn't try to satisfy the predependencies of packages which are on hold. * Fixed conflict-related assertion failure. (Bug#2784.) * conffiles do not cause file conflicts if the conflicting package is in the `configuration only' state. (Bug#2720.) * Fixed messages where available version number was reported as installed version in conflict and dependency messages. (Bug#2654, Bug#2974.) * New format .deb files are default even for a.out compiles (but a.out version of dpkg is in old format). * Characters @:= (at colon equals) in package names now strictly forbidden everywhere (_ is still allowed in existing packages). * New dpkg --print-installation-architecture option prints installation architecture (compiled in), rather than build architecture (determined from gcc -print-libgcc-file-name). * Version messages show whether compiled a.out or ELF (i386 only). * Fixed missing space in version syntax error messages. * Manpage dpkg.8 installed with warning about inaccuracy. * Guidelines don't say to stop and restart daemons in runlevels 2345; instead they say to start in 2345 and stop in 016. * Guidelines and version messages say just Debian Linux. * Guidelines typo fix `"stop2' => `"stop"'. (Bug#2867.) * doc/Makefile.in clean properly deletes various guidelines.info* files. -- Ian Jackson <ian@chiark.chu.cam.ac.uk> Thu, 16 May 1996 00:01:21 +0100
Diffstat (limited to 'debian.buildscript')
-rw-r--r--debian.buildscript23
1 files changed, 23 insertions, 0 deletions
diff --git a/debian.buildscript b/debian.buildscript
new file mode 100644
index 000000000..6a85cd771
--- /dev/null
+++ b/debian.buildscript
@@ -0,0 +1,23 @@
+#!/bin/sh
+set -e -x
+really ./debian.rules clean
+./debian.rules diff source
+
+./debian.rules build
+really ./debian.rules binary
+
+curd="`pwd`"
+newd="`basename \"$curd\"`"elf
+rm -rf ../"$newd"
+cp -dpR . ../"$newd"
+
+PATH=/usr/i486-linuxaout/bin:$PATH
+export PATH
+
+really ./debian.rules clean
+./debian.rules build
+really ./debian.rules binary
+
+version=`sed -n 's/^version=//p' debian.rules`
+perl debian.mkchanges "$version" <debian.changestemplate \
+ | pgp-auto -fast >dpkg-$version.`dpkg --print-architecture`.changes