summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2015-08-09 05:38:12 +0200
committerGuillem Jover <guillem@debian.org>2015-09-14 05:44:07 +0200
commit3ce3a7adeb8c815734a35b95aee96bacd1aafde4 (patch)
tree9ec9bb3cdfc2c335697746347c5d43122c5024ee /debian/rules
parent56a777da0bc20dd1c49564e2a97fc7fdfe93aa51 (diff)
downloaddpkg-3ce3a7adeb8c815734a35b95aee96bacd1aafde4.tar.gz
debian: Do not change libdir for the entire dpkg
This changes too many directories that are expected to be non-multiarch aware. Instead perform the moving to the correct multiarch directories in debian/rules. Closes: #794977
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 6 insertions, 1 deletions
diff --git a/debian/rules b/debian/rules
index f4bd7bf42..0c535a9b5 100755
--- a/debian/rules
+++ b/debian/rules
@@ -38,6 +38,7 @@ ifeq (,$(filter maintainer-build,$(DEB_BUILD_OPTIONS)))
endif
D := $(CURDIR)/debian/tmp
+D_MA := $(D)/usr/lib/$(DEB_HOST_MULTIARCH)
# Create configure script if necessary, automake handles rebuilding it.
configure:
@@ -57,7 +58,6 @@ build-tree/config.status: configure
--infodir=\$${datadir}/info \
--sysconfdir=/etc \
--sbindir=/sbin \
- --libdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) \
--localstatedir=/var \
--with-zlib \
--with-liblzma \
@@ -86,6 +86,11 @@ install: check
cd build-tree && $(MAKE) DESTDIR=$(D) install
+ # Passing --libdir to configure has too many side effects, install
+ # the paths into Multi-Arch directories here instead.
+ mkdir -p $(D_MA)
+ mv $(D)/usr/lib/libdpkg.a $(D_MA)
+
ifeq (yes,$(shell dpkg-vendor --derives-from Ubuntu && echo yes))
# Ubuntu's «i386» architecture is built for i686 (the Debian default
# is i586).