summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2015-06-27 03:09:26 +0200
committerGuillem Jover <guillem@debian.org>2015-07-30 06:39:24 +0200
commit6703756a6c7610549a1f05d0e87cddac3fc563d5 (patch)
tree44361c172d33cbdf1330f3daac503295e1747b49 /debian/rules
parent02e2060504f1c8dbbe5dec8211beaf945350c789 (diff)
downloaddpkg-6703756a6c7610549a1f05d0e87cddac3fc563d5.tar.gz
debian: Group all dpkg-architecture variables together
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules10
1 files changed, 4 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index f447cd765..950d8df8a 100755
--- a/debian/rules
+++ b/debian/rules
@@ -17,20 +17,18 @@ dpkg_buildflags = \
DEB_CXXFLAGS_MAINT_APPEND="$(WFLAGS)" \
$(CURDIR)/run-script perl scripts/dpkg-buildflags.pl
-# These are used for cross-compiling and for saving the configure script
-# from having to guess our platform (since we know it already)
-DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
DEB_BUILD_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
+DEB_HOST_GNU_TYPE ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
+DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
+# Support cross-compiling.
ifeq ($(DEB_BUILD_GNU_TYPE), $(DEB_HOST_GNU_TYPE))
confflags += --build=$(DEB_HOST_GNU_TYPE)
else
confflags += --build=$(DEB_BUILD_GNU_TYPE) --host=$(DEB_HOST_GNU_TYPE)
endif
-# Don't enable everything on all platforms
-DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
-
+# Do not enable everything on all platforms.
ifeq ($(DEB_HOST_ARCH_OS),linux)
confflags += --with-selinux
endif