summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2015-09-14 16:37:07 +0200
committerGuillem Jover <guillem@debian.org>2015-09-14 17:39:54 +0200
commit9043cdef192332f3a0fc710731d3bf7e73aaa3aa (patch)
treeda7ffa295715818f18d0c8b9564225d06c3e7de6 /debian/rules
parenteae0b17537596dc5589598c4724feb14c5d7e949 (diff)
downloaddpkg-9043cdef192332f3a0fc710731d3bf7e73aaa3aa.tar.gz
debian: Use --with-devlibdir to only switch libdpkg-dev to a multiarch dir
The perl plugins and dselect methods need to use the non-multiarch directory, or things break. We can use now the new option to only install the C libdpkg files in a multiarch enabled path. The fix from commit 3ce3a7adeb8c815734a35b95aee96bacd1aafde4 was not correct, as libdpkg.pc was not moved to the multiarch directory and was making the build fail, because it needs to have a libdir matching the directory where the library was installed.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules7
1 files changed, 1 insertions, 6 deletions
diff --git a/debian/rules b/debian/rules
index 0c535a9b5..6a54c6cf0 100755
--- a/debian/rules
+++ b/debian/rules
@@ -38,7 +38,6 @@ ifeq (,$(filter maintainer-build,$(DEB_BUILD_OPTIONS)))
endif
D := $(CURDIR)/debian/tmp
-D_MA := $(D)/usr/lib/$(DEB_HOST_MULTIARCH)
# Create configure script if necessary, automake handles rebuilding it.
configure:
@@ -59,6 +58,7 @@ build-tree/config.status: configure
--sysconfdir=/etc \
--sbindir=/sbin \
--localstatedir=/var \
+ --with-devlibdir=\$${prefix}/lib/$(DEB_HOST_MULTIARCH) \
--with-zlib \
--with-liblzma \
--with-bz2
@@ -86,11 +86,6 @@ install: check
cd build-tree && $(MAKE) DESTDIR=$(D) install
- # Passing --libdir to configure has too many side effects, install
- # the paths into Multi-Arch directories here instead.
- mkdir -p $(D_MA)
- mv $(D)/usr/lib/libdpkg.a $(D_MA)
-
ifeq (yes,$(shell dpkg-vendor --derives-from Ubuntu && echo yes))
# Ubuntu's «i386» architecture is built for i686 (the Debian default
# is i586).