summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
authorRaphaël Hertzog <hertzog@debian.org>2011-07-27 20:10:24 +0200
committerRaphaël Hertzog <hertzog@debian.org>2011-07-28 14:03:06 +0200
commita372b6a165de8876434828d2f7884b6e8840349b (patch)
tree764c8b5aecfe73ff65481cad635998e61b7a5ef4 /debian/rules
parent84f3154aee09f649e78e78f0f0affe160d73296e (diff)
downloaddpkg-a372b6a165de8876434828d2f7884b6e8840349b.tar.gz
debian/rules: introduce a maintainer build mode
Adding "maintainer-build" to DEB_BUILD_OPTS changes some compilation settings to make the build more useful for maintainers. For instance it enables the silent rules so that it's easier to spot the warnings. It would be nice to also enable -Werror but that requires further investigation since enabling this option results in ./configure not working any more due to warnings generated by several of the test programs compiled by ./configure itself.
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules5
1 files changed, 3 insertions, 2 deletions
diff --git a/debian/rules b/debian/rules
index 8d6aee1f1..190622932 100755
--- a/debian/rules
+++ b/debian/rules
@@ -33,7 +33,9 @@ DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
ifeq ($(DEB_HOST_ARCH_OS),linux)
confflags += --with-selinux
endif
-
+ifeq (,$(filter maintainer-build,$(DEB_BUILD_OPTIONS)))
+ confflags += --disable-silent-rules
+endif
# Create configure script if necessary, automake handles rebuilding it.
configure:
@@ -48,7 +50,6 @@ build-tree/config.status: configure
install -d build-tree
cd build-tree && ../configure $(confflags) \
CFLAGS="$(CFLAGS)" CXXFLAGS="$(CXXFLAGS)" \
- --disable-silent-rules \
--prefix=/usr \
--mandir=\$${datadir}/man \
--infodir=\$${datadir}/info \