summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorChristian Perrier <bubulle@debian.org>2009-08-19 08:53:45 +0200
committerChristian Perrier <bubulle@debian.org>2009-08-19 08:53:45 +0200
commit1e93ee6fac346aecc0a0aa307931284a5d8f5395 (patch)
tree47300af3355f5099e32e59b03cf0f62725d1cd74 /debian
parent66abf29395eea02e861ed41cd43092c6a29d6d45 (diff)
parent41d56b350b196aaca09d3901741aaada1138e862 (diff)
downloaddpkg-1e93ee6fac346aecc0a0aa307931284a5d8f5395.tar.gz
Merged changes
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog34
-rw-r--r--debian/control2
-rw-r--r--debian/dpkg.cron.daily10
-rwxr-xr-xdebian/rules3
4 files changed, 45 insertions, 4 deletions
diff --git a/debian/changelog b/debian/changelog
index f61e6a18e..4d6e0def6 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -12,7 +12,7 @@ dpkg (1.15.4) UNRELEASED; urgency=low
handled already by “dpkg-deb -I”.
* Properly mark packages being purged for disappearance from the database.
This will make the status database not be left behind with traces of old
- not-installed packages.
+ not-installed packages. Closes: #472208
* On parse mark not-installed leftover packages for automatic removal from
the database on next dump. This obsoletes the --forget-old-unavail option,
thus making it now a no-op. Closes: #33394, #429262
@@ -26,6 +26,11 @@ dpkg (1.15.4) UNRELEASED; urgency=low
* Add uClibc Linux support to ostable and triplettable. Closes: #455501
* Add uClinux support to ostable and triplettable.
Thanks to Simon Richter <sjr@debian.org>.
+ * When aborting due to file conflicts print the version of the conflicted
+ package. Closes: #540019
+ * Remove double slash in database path visible to the user in some error
+ conditions.
+ * Stop macthing sparc64-*-* GNU triplets with sparc Debian architecture.
[ Raphael Hertzog ]
* Replace install-info by a wrapper around GNU's install-info. The wrapper
@@ -44,6 +49,31 @@ dpkg (1.15.4) UNRELEASED; urgency=low
Closes: #537800
* Fix update-alternatives to mention the correct slave link that can't
be installed due to a conflicting file instead of quoting the master link.
+ * Add support for extra override file in dpkg-scanpackages. Thanks to Robert
+ Millan for the patch. Closes: #537559
+ * Add support for extra override file in dpkg-scansources.
+ * Document format of extra override file in a new manual page
+ deb-extra-override(5).
+ * Update sample in dpkg-gensymbols(1) to give an accurate listing of
+ 64 bit arches. Thanks to Julien Cristau for the patch. Closes: #540382
+ * Create /etc/cron.daily/dpkg to handle the backup of
+ /var/lib/dpkg/status in /var/backups. This is taken out of the cron
+ package and need no conflicts/breaks as the code does nothing if
+ the current status file is already backupped. Thanks to Leo 'costela'
+ Antunes <costela@debian.org> for the patch. Closes: #541412
+ * Change behaviour of dpkg --merge-avail to not update a package's
+ information if the version provided is older than the one already listed
+ in the available file. Thanks to Ian Jackson
+ <ian@davenant.greenend.org.uk> for the patch. Closes: #496114
+ * dpkg-architecture can now export DEB_{HOST,BUILD}_ARCH_{BITS,ENDIAN}
+ (pointer size and endianness):
+ - cputable (in dpkg) modified to contain those information
+ - dpkg-dev depends on dpkg (>= 1.15.4) to ensure that we have an updated
+ cputable (and so that a versioned build-dependency on dpkg-dev is enough
+ to use this new feature)
+ Closes: #531307
+ * Split overly long Binary: field values over multiple lines. This is
+ allowed since policy 3.8.3. Closes: #494714
[ Modestas Vainius ]
* Provide a meaningful label for dpkg-gensymbols diff.
@@ -62,8 +92,8 @@ dpkg (1.15.4) UNRELEASED; urgency=low
* Slovak (Ivan Masár). Closes: #537741
[ Updated man page translations ]
- * German (Helge Kreutzmann), proofreading by Jens Seidel.
* French completed (Christian Perrier).
+ * German (Helge Kreutzmann), proofreading by Jens Seidel.
* Swedish (Peter Krefting).
[ Updated scripts translations ]
diff --git a/debian/control b/debian/control
index 611b5c69d..925a94942 100644
--- a/debian/control
+++ b/debian/control
@@ -40,7 +40,7 @@ Package: dpkg-dev
Section: utils
Priority: optional
Architecture: all
-Depends: dpkg (>= 1.14.6), perl5, perl-modules, bzip2, lzma,
+Depends: dpkg (>= 1.15.4), perl5, perl-modules, bzip2, lzma,
patch (>= 2.2-1), make, binutils, libtimedate-perl
Recommends: gcc | c-compiler, build-essential, fakeroot, gnupg, gpgv
Suggests: debian-keyring, debian-maintainers
diff --git a/debian/dpkg.cron.daily b/debian/dpkg.cron.daily
new file mode 100644
index 000000000..99f4f6be2
--- /dev/null
+++ b/debian/dpkg.cron.daily
@@ -0,0 +1,10 @@
+#!/bin/sh
+
+# Backup the 7 last versions of dpkg's status file
+if cd /var/backups ; then
+ if ! cmp -s dpkg.status.0 /var/lib/dpkg/status ; then
+ cp -p /var/lib/dpkg/status dpkg.status
+ savelog -c 7 dpkg.status >/dev/null
+ fi
+fi
+
diff --git a/debian/rules b/debian/rules
index 05c08ca58..b302e9346 100755
--- a/debian/rules
+++ b/debian/rules
@@ -84,6 +84,7 @@ binary-arch: install
dh_testdir -a
dh_testroot -a
dh_install --sourcedir=debian/tmp -a
+ dh_installcron -a
dh_installlogrotate -a
install -d debian/dpkg/sbin
@@ -107,7 +108,7 @@ binary-indep: install
dh_testdir -i
dh_testroot -i
dh_install --sourcedir=debian/tmp -i -XDpkg/Gettext.pm
-
+ dh_installcron -i
dh_installchangelogs -i ChangeLog*
dh_installdocs -i
dh_link -i