summaryrefslogtreecommitdiff
path: root/debian
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2009-09-26 07:02:41 +0200
committerGuillem Jover <guillem@debian.org>2010-02-25 09:37:42 +0100
commit8cf1ec6108d944eaecbdca7a9b52f92ee0db6a8b (patch)
treeb114a58699ad178de435bd6168b9a54bb830efc2 /debian
parentfc39dea9ec2ed9528f39eb288e94932913f70bf8 (diff)
downloaddpkg-8cf1ec6108d944eaecbdca7a9b52f92ee0db6a8b.tar.gz
Dynamically link against all external libraries
This includes libbz2 and zlib for dpkg-deb and and libselinux for dpkg on GNU/Linux.
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/dpkg.lintian-overrides2
-rwxr-xr-xdebian/rules6
3 files changed, 5 insertions, 5 deletions
diff --git a/debian/changelog b/debian/changelog
index 3da5ca1ca..1f79c21ce 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -124,6 +124,8 @@ dpkg (1.15.6) UNRELEASED; urgency=low
The proper solution to this is to let the build system choose the
appropriate pkg-config binary for the build or host system in the same
way pkg.m4 is handling it now. Closes: #551118
+ * Dynamically link against all external libraries. This includes libbz2
+ and zlib for dpkg-deb and and libselinux for dpkg on GNU/Linux.
[ Modestas Vainius ]
* Implement symbol patterns (Closes: #563752). From now on, it is possible to
diff --git a/debian/dpkg.lintian-overrides b/debian/dpkg.lintian-overrides
index cbbb25eac..6b75f5408 100644
--- a/debian/dpkg.lintian-overrides
+++ b/debian/dpkg.lintian-overrides
@@ -1,8 +1,6 @@
dpkg: redundant-origin-field
dpkg: redundant-bugs-field
dpkg: arch-dep-package-has-big-usr-share
-# By design, to be able to recover from broken/missing zlib
-dpkg: embedded-zlib ./usr/bin/dpkg-deb
# False positives, we read from a file not from a tty
dpkg: read-in-maintainer-script preinst:39
dpkg: read-in-maintainer-script preinst:40
diff --git a/debian/rules b/debian/rules
index 6fc0ee461..14edffbf7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -31,7 +31,7 @@ endif
DEB_HOST_ARCH_OS ?= $(shell dpkg-architecture -qDEB_HOST_ARCH_OS)
ifeq ($(DEB_HOST_ARCH_OS),linux)
- confflags += --with-selinux=static
+ confflags += --with-selinux
endif
@@ -54,8 +54,8 @@ build-tree/config.status: configure
--infodir=\$${datadir}/info \
--sysconfdir=/etc \
--localstatedir=/var/lib \
- --with-zlib=static \
- --with-bz2=static
+ --with-zlib \
+ --with-bz2
# Build the package in build-tree
build: build-tree/config.status