summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorRaphaël Hertzog <hertzog@debian.org>2010-08-11 15:50:56 +0200
committerRaphaël Hertzog <hertzog@debian.org>2010-08-11 15:50:56 +0200
commit4be28d99de2c8fe27c6c16bc9c114f7cef550f79 (patch)
treefca8b17040ee0d54bb37a56bf4ca1530009dd663 /man/Makefile.am
parent58c7cd30d692652b1d533a809c1aea397d35eacf (diff)
downloaddpkg-4be28d99de2c8fe27c6c16bc9c114f7cef550f79.tar.gz
Fix install target in man/Makefile.am
Commit 39c6dab89bbea9fe336f869b65e33102ba238205 introduced a regression: make install during a package build in a tree generated by make dist would no longer install the manual page... because they are already built and available in $(srcdir) while $(CURDIR) was ok for the case where the manual pages are not pre-built. No we try both paths and pick the first one that exists.
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 494c0ed5a..cdd3353e0 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -50,6 +50,8 @@ install-data-local-yes:
for trans in $(dist_man_MANS); do \
if [ -f $(CURDIR)/$$lang/$$trans ]; then \
files="$$files $(CURDIR)/$$lang/$$trans"; \
+ elif [ -f $(srcdir)/$$lang/$$trans ]; then \
+ files="$$files $(srcdir)/$$lang/$$trans"; \
fi; \
done; \
$(MAKE) install-man \