summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2011-09-19 17:01:23 +0200
committerGuillem Jover <guillem@debian.org>2011-09-19 17:28:27 +0200
commit822ea85c7c16d45f932f9c86f5ac0a04a8c304c2 (patch)
tree292f792807487c667e3328590b29503457b1c806 /man/Makefile.am
parent572caf52457bc4158f6443aa455414e1d5e861dd (diff)
downloaddpkg-822ea85c7c16d45f932f9c86f5ac0a04a8c304c2.tar.gz
build: Use po4a --srcdir and --builddir
This avoids the absolute paths in the po4a Discard output messages, and simplifies the build infrastructure by not needing the change directory gymnastics and builddir po4a variable in the po4a.cfg file. It's been enough time now since #538136 was filed precisely for dpkg needs, to rely on these “new” options.
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am8
1 files changed, 3 insertions, 5 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index da4279de9..d989bf8d4 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -72,7 +72,7 @@ PO4A_V = $(PO4A_V_$(V))
PO4A_V_ = $(PO4A_V_$(AM_DEFAULT_VERBOSITY))
PO4A_V_0 = @echo " PO4A $@";
-PO4A_COMMON_OPTS = --previous --variable builddir=$(CURDIR)
+PO4A_COMMON_OPTS = --previous --srcdir $(srcdir) --destdir $(CURDIR)
PO4A_BUILD_OPTS = $(PO4A_COMMON_OPTS) --no-backups
all-local: all-local-@USE_PO4A@
@@ -82,8 +82,7 @@ all-local-yes: man.stamp
# FIXME: Use a stamp file until po4a supports them internally.
man.stamp:
- $(PO4A_V) cd $(srcdir) && \
- $(PO4A) $(PO4A_BUILD_OPTS) po/po4a.cfg
+ $(PO4A_V) $(PO4A) $(PO4A_BUILD_OPTS) $(srcdir)/po/po4a.cfg
$(AM_V_at) touch $@
clean-local: clean-local-@USE_PO4A@
@@ -96,8 +95,7 @@ clean-local-yes:
.PHONY: update-po
update-po:
- $(PO4A_V) cd $(srcdir) && \
- $(PO4A) $(PO4A_BUILD_OPTS) --force po/po4a.cfg
+ $(PO4A_V) $(PO4A) $(PO4A_BUILD_OPTS) --force $(srcdir)/po/po4a.cfg
install-data-local: install-data-local-@USE_PO4A@