summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2009-09-15 19:16:38 +0200
committerGuillem Jover <guillem@debian.org>2009-09-15 20:12:17 +0200
commite628950c4affe51bf51e6af6f76827c465efc8e8 (patch)
tree2d63c6d63d450db40cfa66b507768765c507069c /man/Makefile.am
parent3ca41e2ae851f012a28914ebb79eb472834e2d72 (diff)
downloaddpkg-e628950c4affe51bf51e6af6f76827c465efc8e8.tar.gz
Make the build silent by default
Make it verbose when building the Debian packages.
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am18
1 files changed, 13 insertions, 5 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index 8ee55cd92..ca7209fe4 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -1,5 +1,13 @@
## Process this file with automake to produce Makefile.in
+PO4A_V = $(PO4A_V_$(V))
+PO4A_V_ = $(PO4A_V_$(AM_DEFAULT_VERBOSITY))
+PO4A_V_0 = @echo " PO4A $@";
+
+PO4A_RM_V = $(PO4A_RM_V_$(V))
+PO4A_RM_V_ = $(PO4A_RM_V_$(AM_DEFAULT_VERBOSITY))
+PO4A_RM_V_0 = @echo " PO4ARM $@";
+
all-local: all-local-@USE_NLS@
all-local-no:
@@ -11,20 +19,20 @@ PO4A_CLEAN_OPTS = $(PO4A_COMMON_OPTS) --rm-backups --rm-translations
# FIXME: Use a stamp file until po4a supports them internally.
man.stamp:
- cd $(srcdir) && \
+ $(PO4A_V) cd $(srcdir) && \
po4a $(PO4A_BUILD_OPTS) po/po4a.cfg
- touch $@
+ $(AM_V_at) touch $@
clean-local: clean-local-@USE_NLS@
clean-local-no:
clean-local-yes:
- cd $(srcdir) && \
+ $(PO4A_RM_V) cd $(srcdir) && \
po4a $(PO4A_CLEAN_OPTS) po/po4a.cfg
- rm -f man.stamp
+ $(AM_V_at) rm -f man.stamp
update-po:
- cd $(srcdir) && \
+ $(PO4A_V) cd $(srcdir) && \
po4a $(PO4A_BUILD_OPTS) --force po/po4a.cfg
# Extract the list of languages from the po4a config file.