summaryrefslogtreecommitdiff
path: root/man/Makefile.am
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2016-11-01 06:21:18 +0100
committerGuillem Jover <guillem@debian.org>2016-11-03 06:03:35 +0100
commitee8975322f93e41ccd5787ebb6cadaecc81cadf3 (patch)
tree9f54df5e375e2c177c00b681717d5de44a56807a /man/Makefile.am
parentf89e053f3e3a6f0f73a9ce2c8dd2c72db93d44bb (diff)
downloaddpkg-ee8975322f93e41ccd5787ebb6cadaecc81cadf3.tar.gz
scripts: Add support for .buildinfo files
The .buildinfo files are a new type of control files, similar to the .changes files, meant to describe the environment of a build and its artifacts. They are meant to be added to the Debian archive to allow independent parties to reproduce a build and verify the result. Specifications for .buildinfo are available at: <https://wiki.debian.org/ReproducibleBuilds/BuildinfoSpecification> This patch adds support for .buildinfo files in Dpkg::Control, adds new .buildinfo fields to Dpkg::Control::Fields, a new builtin-system-build-paths Dpkg::Vendor hook, and adds a new script named dpkg-genbuildinfo, that will now be called by dpkg-buildpackage before generating the .changes file. [ntyni@debian.org: small changes. ] Closes: #138409 Based-on-patch-by: Jérémy Bobbio <lunar@debian.org> Signed-off-by: Guillem Jover <guillem@debian.org>
Diffstat (limited to 'man/Makefile.am')
-rw-r--r--man/Makefile.am4
1 files changed, 4 insertions, 0 deletions
diff --git a/man/Makefile.am b/man/Makefile.am
index bf468a250..e5f3c54a8 100644
--- a/man/Makefile.am
+++ b/man/Makefile.am
@@ -1,6 +1,7 @@
## Process this file with automake to produce Makefile.in
man_MANS = \
+ deb-buildinfo.5 \
deb-changelog.5 \
deb-changes.5 \
deb-conffiles.5 \
@@ -30,6 +31,7 @@ man_MANS = \
dpkg-deb.1 \
dpkg-distaddfile.1 \
dpkg-divert.1 \
+ dpkg-genbuildinfo.1 \
dpkg-genchanges.1 \
dpkg-gencontrol.1 \
dpkg-gensymbols.1 \
@@ -70,6 +72,7 @@ endif
CLEANFILES = $(man_MANS)
EXTRA_DIST = \
+ deb-buildinfo.man \
deb-changelog.man \
deb-changes.man \
deb-conffiles.man \
@@ -99,6 +102,7 @@ EXTRA_DIST = \
dpkg-deb.man \
dpkg-distaddfile.man \
dpkg-divert.man \
+ dpkg-genbuildinfo.man \
dpkg-genchanges.man \
dpkg-gencontrol.man \
dpkg-gensymbols.man \