summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2009-11-19 05:41:55 +0100
committerGuillem Jover <guillem@debian.org>2009-11-20 04:10:25 +0100
commit48a5ef95febedf411e67a68788de5048b9dcf8f2 (patch)
treea8994cd755f603b122d8c49ea233c5e414038a95 /scripts/Makefile.am
parent02f3d0bb686d384a2ebe878084cac94008fa516f (diff)
downloaddpkg-48a5ef95febedf411e67a68788de5048b9dcf8f2.tar.gz
build: Merge the mkdir_t_tmp target into the check target
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am4
1 files changed, 1 insertions, 3 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 27ff34da9..2062f5242 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -172,10 +172,8 @@ clean-local:
[ ! -d t.tmp ] || chmod -R +w t.tmp
rm -fr t.tmp
-mkdir_t_tmp:
+check: $(TEST_FILES) $(wildcard $(srcdir)/t/200_Dpkg_Shlibs/ld.so.conf*)
$(mkdir_p) t.tmp
-
-check: $(TEST_FILES) $(wildcard $(srcdir)/t/200_Dpkg_Shlibs/ld.so.conf*) mkdir_t_tmp
# a bit hacky...
cp -dRl $(srcdir)/t/200_Dpkg_Shlibs/ld.so.conf* t.tmp/
PATH="$(top_builddir)/src:$(top_builddir)/scripts:$(PATH)" srcdir=$(srcdir) PERL5LIB=$(srcdir) DPKG_DATADIR=$(srcdir)/.. PERL_DL_NONLAZY=1 $(PERL) -I$(srcdir) "-MExtUtils::Command::MM" "-e" "test_harness($(TEST_VERBOSE), '.')" $(TEST_FILES)