summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2017-03-06 22:28:45 +0100
committerGuillem Jover <guillem@debian.org>2017-05-07 16:34:42 +0200
commit747f3df99aa0263ba684c6ce317310b0c75f72c8 (patch)
treefe5533fc7cda9651f5cd6872818f40b0808b78f3 /scripts/Makefile.am
parent24899e778c30cbbe399c1cc27f4a004faf33b7e1 (diff)
downloaddpkg-747f3df99aa0263ba684c6ce317310b0c75f72c8.tar.gz
build: Use libexec variable for auxiliary internal programs
Using libdir is wrong, and doubly so when being referred from architecture independent files such as perl modules. This affects non-Debian based systems, which might by default use an arch varying libdir per architecture, for example when using the obsolete multilib layout.
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 5583fa960..435f0c5f7 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -128,7 +128,7 @@ do_perl_subst = $(AM_V_GEN) sed \
-e "s:^\#![[:space:]]*/usr/bin/perl:\#!$(PERL):" \
-e "s:our \$$CONFDIR = .*;:our \$$CONFDIR = '$(pkgconfdir)';:" \
-e "s:our \$$ADMINDIR = .*;:our \$$ADMINDIR = '$(admindir)';:" \
- -e "s:our \$$LIBDIR = .*;:our \$$LIBDIR = '$(pkglibdir)';:" \
+ -e "s:our \$$LIBDIR = .*;:our \$$LIBDIR = '$(pkglibexecdir)';:" \
-e "s:our \$$DATADIR = .*;:our \$$DATADIR = '$(pkgdatadir)';:" \
-e "s:our \$$PROGMAKE = .*;:our \$$PROGMAKE = '$(MAKE)';:" \
-e "s:our \$$PROGTAR = .*;:our \$$PROGTAR = '$(TAR)';:" \