summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorRaphaël Hertzog <hertzog@debian.org>2010-02-18 19:40:51 +0100
committerRaphaël Hertzog <hertzog@debian.org>2010-06-09 23:36:37 +0200
commitcab5af04fadcd939a7becd5fcb25dcfb7bc121dd (patch)
tree8edc589fa65db213831c60222295fa3a0fbf45b2 /scripts/Makefile.am
parenta9bdb8f80f6c9aabfe63032940b523ec0513698d (diff)
downloaddpkg-cab5af04fadcd939a7becd5fcb25dcfb7bc121dd.tar.gz
update-alternatives: rewritten in C
update-alternative has been rewritten as a mostly standalone C program. It has thus been moved to utils/ instead of scripts/ together with its README and its test suite. This rewrite is based on some initial conversion work done by Guillem Jover <guillem@debian.org>. The program now logs to /var/log/alternatives.log instead of dpkg.log. The logrotate file has been updated to deal with that file too.
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am12
1 files changed, 0 insertions, 12 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 0296360ec..8d2e64216 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -22,10 +22,6 @@ bin_SCRIPTS = \
dpkg-source \
dpkg-vendor
-if WITH_UPDATE_ALTERNATIVES
-bin_SCRIPTS += update-alternatives
-endif
-
changelogdir = $(pkglibdir)/parsechangelog
changelog_SCRIPTS = \
changelog/debian
@@ -50,7 +46,6 @@ EXTRA_DIST = \
dpkg-source.pl \
dpkg-divert.pl \
dpkg-vendor.pl \
- update-alternatives.pl \
changelog/debian.pl \
$(test_cases) \
$(test_data)
@@ -151,11 +146,6 @@ if BUILD_POD_DOC
rm -f $(DESTDIR)$(man3dir)/$$name.3; \
done
endif
-if WITH_UPDATE_ALTERNATIVES
- $(mkdir_p) $(DESTDIR)$(sysconfdir)/alternatives
- $(mkdir_p) $(DESTDIR)$(admindir)/alternatives
- $(INSTALL_DATA) $(srcdir)/README.alternatives $(DESTDIR)$(sysconfdir)/alternatives/README
-endif
# Ideally we'd use 'sed -i', but unfortunately that's not portable.
install-data-hook:
@@ -171,7 +161,6 @@ if BUILD_POD_DOC
rm -f $(DESTDIR)$(man3dir)/`echo $$module | sed -e 's|/|::|g' -e 's/\.pm$$/.3/'`; \
done
endif
- rm -f $(DESTDIR)$(sysconfdir)/alternatives/README
TEST_VERBOSE= 0
@@ -191,7 +180,6 @@ test_cases = \
t/750_Dpkg_Substvars.t \
t/800_Dpkg_IPC.t \
t/850_Dpkg_Compression.t \
- t/900_update_alternatives.t \
t/910_merge_changelogs.t
check_DATA = \