summaryrefslogtreecommitdiff
path: root/scripts/Makefile.am
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2014-05-04 16:25:21 +0200
committerGuillem Jover <guillem@debian.org>2014-05-17 13:30:52 +0200
commitfa48a94434acf00681259bbe8f7acb0efad76153 (patch)
tree98161a607f0e8ae7a698553571191a7e4e427669 /scripts/Makefile.am
parent79a6978160ccf752d058786ab8fb61ad7fa1646a (diff)
downloaddpkg-fa48a94434acf00681259bbe8f7acb0efad76153.tar.gz
scripts: Add template test cases for most modules
This at least tests if the module in question can be use'ed correctly, and gives a more realistic code coverage report. The remaining modules should be covered by one of their parents.
Diffstat (limited to 'scripts/Makefile.am')
-rw-r--r--scripts/Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/scripts/Makefile.am b/scripts/Makefile.am
index 45cb3d487..fc149a411 100644
--- a/scripts/Makefile.am
+++ b/scripts/Makefile.am
@@ -194,17 +194,34 @@ test_cases = \
t/Dpkg_Package.t \
t/Dpkg_Shlibs_Cppfilt.t \
t/Dpkg_Shlibs.t \
+ t/Dpkg_BuildEnv.t \
+ t/Dpkg_BuildFlags.t \
t/Dpkg_BuildOptions.t \
+ t/Dpkg_BuildProfiles.t \
+ t/Dpkg_Checksums.t \
+ t/Dpkg_ErrorHandling.t \
+ t/Dpkg_Exit.t \
+ t/Dpkg_File.t \
+ t/Dpkg_Gettext.t \
+ t/Dpkg_Conf.t \
t/Dpkg_Deps.t \
t/Dpkg_Path.t \
t/Dpkg_Util.t \
+ t/Dpkg_Vars.t \
+ t/Dpkg_Interface_Storable.t \
t/Dpkg_Vendor.t \
t/Dpkg_Changelog.t \
t/Dpkg_Changelog_Ubuntu.t \
t/Dpkg_Control.t \
+ t/Dpkg_Index.t \
t/Dpkg_Substvars.t \
t/Dpkg_IPC.t \
t/Dpkg_Compression.t \
+ t/Dpkg_Source_Functions.t \
+ t/Dpkg_Source_Patch.t \
+ t/Dpkg_Source_Quilt.t \
+ t/Dpkg_Source_Archive.t \
+ t/Dpkg_Source_Package.t \
t/Dpkg_Dist_Files.t \
t/merge_changelogs.t