summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorScott James Remnant <scott@netsplit.com>2005-06-12 15:52:43 +0100
committerScott James Remnant <scott@netsplit.com>2005-06-12 15:52:43 +0100
commit3748a23e47c1af76f291f3c4caa98eefc45ff508 (patch)
treefb2bdcec072f8317bca5eb0a93b3e1df07028e51 /src/Makefile.am
parent5d931a4571570a705ed3ac40a456795f85339601 (diff)
downloaddpkg-3748a23e47c1af76f291f3c4caa98eefc45ff508.tar.gz
dpkg (1.13.9) unstable; urgency=low
The "On like Donkey Kong" Release. * Only open the log file when we first need to write to it, this avoids the need to suppress errors when not root which fakeroot defeated anyway. * Stop dpkg-source clobbering an existing .orig directory during unpacking. Closes: #21236. * Allow an alternate output directory to be specified to dpkg-source by giving a second argument to -x. Closes: #246802, #282323. * Added .arch-inventory to default diff ignore regexp. Closes: #304297. SELinux support (Manoj Srivastava): * On SELinux-enabled systems, try to set the security context when the package is unpacked. Closes: #193653, #249496, #307139. * Added build-dependancy on libselinux1-dev. Improvements to dpkg-source (Brendan O'Dea): * Support unpacking of "Wig And Pen" (Format 2.0) source packages. * Multiple pristine upstream tarballs allowed. * Native and upstream tarballs may be bzip2-compressed instead of gzip, as may the debian diff or tarball. * Unsupported format error fixed to output the unsupported format rather than the supported one. Closes: #156317. -- Scott James Remnant <scott@netsplit.com> Sun, 12 Jun 2005 15:52:43 +0100
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index bdccc631f..cbc062825 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -25,14 +25,15 @@ dpkg_SOURCES = \
select.c \
update.c
-dpkg_LDADD = $(LIBINTL) ../lib/libdpkg.a $(ZLIB_LIBS) $(BZ2_LIBS)
+dpkg_LDADD = \
+ $(LIBINTL) ../lib/libdpkg.a $(ZLIB_LIBS) $(BZ2_LIBS) $(SELINUX_LIBS)
dpkg_query_SOURCES = \
errors.c \
filesdb.c filesdb.h \
query.c
-dpkg_query_LDADD = $(LIBINTL) ../lib/libdpkg.a $(ZLIB_LIBS) $(BZ2_LIBS)
+dpkg_query_LDADD = $(LIBINTL) ../lib/libdpkg.a
install-data-local: