summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2009-02-11 03:28:19 +0200
committerGuillem Jover <guillem@debian.org>2009-03-03 04:41:44 +0200
commit45e5ee9e4c9195a488c2e0e246b855e4bcbe6b4f (patch)
treef5485e8992def3402ed84fa65243ed883b4b8b35 /src/Makefile.am
parent2c0667d06a38c3a31ab43b79a979f29e5fcf0cf3 (diff)
downloaddpkg-45e5ee9e4c9195a488c2e0e246b855e4bcbe6b4f.tar.gz
Refactor package array handling
Create a new pkg_array structure, and two new functions to initialize from the db, and to sort the array.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d621431ec..cb3ec9336 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -21,7 +21,7 @@ dpkg_SOURCES = \
help.c \
main.c main.h \
packages.c \
- pkg-array.c \
+ pkg-array.c pkg-array.h \
pkg-show.c \
processarc.c \
remove.c \
@@ -39,7 +39,7 @@ dpkg_LDADD = \
dpkg_query_SOURCES = \
filesdb.c filesdb.h \
- pkg-array.c \
+ pkg-array.c pkg-array.h \
pkg-show.c \
query.c