summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorGuillem Jover <guillem@debian.org>2012-07-23 04:36:16 +0200
committerGuillem Jover <guillem@debian.org>2013-10-17 07:58:15 +0200
commitb4dd2a29d6b7e0a2f65021307481c9a575729aa1 (patch)
treeb889a5acc253bc629a09aa4f9d95987f2ca350a5 /src/Makefile.am
parent1759c8fd3366450e0cb66d6ad0a1420e33848226 (diff)
downloaddpkg-b4dd2a29d6b7e0a2f65021307481c9a575729aa1.tar.gz
dpkg: Add new --verify command
For now this checks that the files have not been modified by computing and comparing their md5sum hashes against the ones in the database. The only currently supported output format will try to mimick the one from «rpm --verify», but the default might change in the future in case it is found cumbersome or lacking, and as such programs parsing the command output should be explicit about the format they want. Closes: #187019
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index d96578ec7..146ad5ae3 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -53,7 +53,9 @@ dpkg_SOURCES = \
select.c \
trigproc.c \
unpack.c \
- update.c
+ update.c \
+ verify.c \
+ $(nil)
dpkg_LDADD = \
$(LDADD) \