summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorRaphaël Hertzog <hertzog@debian.org>2010-04-16 11:56:17 +0200
committerRaphaël Hertzog <hertzog@debian.org>2010-04-16 16:49:42 +0200
commitd5b15f56fbc93983005cf2f9cc1117a3bbb3670c (patch)
tree4204da1f8a94ef29b524add42589e39bf89f7ce6 /src/Makefile.am
parent246cf59f8cb555bdaddd36e01d4b57a5e5ac3c7f (diff)
downloaddpkg-d5b15f56fbc93983005cf2f9cc1117a3bbb3670c.tar.gz
dpkg: export DPKG_LIBDIR to maintainer scripts
It can be used to find out the location of some internal dpkg programs that might be called from maintainer scripts. That way we can avoid hardcoding /usr/lib/dpkg and maintainer scripts will still work when called from a dpkg manually installed in /usr/local for example.
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
index b3f2fe582..ddde846bb 100644
--- a/src/Makefile.am
+++ b/src/Makefile.am
@@ -6,6 +6,7 @@ pkgconfdir = $(sysconfdir)/@PACKAGE@
AM_CPPFLAGS = \
-DLOCALEDIR=\"$(localedir)\" \
-DADMINDIR=\"$(admindir)\" \
+ -DPKGLIBDIR=\"$(pkglibdir)\" \
-idirafter $(top_srcdir)/lib/compat \
-I$(top_builddir) \
-I$(top_srcdir)/lib