summaryrefslogtreecommitdiff
path: root/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'debian/rules')
-rwxr-xr-xdebian/rules30
1 files changed, 19 insertions, 11 deletions
diff --git a/debian/rules b/debian/rules
index 01957755a..d79545ec7 100755
--- a/debian/rules
+++ b/debian/rules
@@ -3,7 +3,12 @@
# Copyright © 2004 Scott James Remnant <scott@netsplit.com>
# Copyright © 2006-2012 Guillem Jover <guillem@debian.org>
-WFLAGS := -Wall -Wextra -Wno-unused-parameter -Wno-missing-field-initializers
+WFLAGS := \
+ -Wall -Wextra \
+ -Wno-missing-field-initializers \
+ -Wno-nonnull-compare \
+ -Wno-unused-parameter \
+ $(nil)
# Use the in-tree dpkg-buildflags
dpkg_buildflags = \
@@ -34,8 +39,9 @@ endif
ifeq ($(DEB_HOST_ARCH_OS),linux)
confflags += --with-libselinux
endif
-ifeq (,$(filter maintainer-build,$(DEB_BUILD_OPTIONS)))
+ifeq (,$(filter terse,$(DEB_BUILD_OPTIONS)))
confflags += --disable-silent-rules
+ testflags += TESTSUITEFLAGS=--verbose
endif
ifeq ($(with_start_stop_daemon),no)
@@ -51,15 +57,10 @@ endif
D := $(CURDIR)/debian/tmp
-# Create configure script if necessary, automake handles rebuilding it.
-configure:
- dh_testdir
-
- autoreconf -v -i -f
-
# Configure the build tree
-build-tree/config.status: configure
+build-tree/config.status:
dh_testdir
+ dh_autoreconf
install -d build-tree
cd build-tree && ../configure $(confflags) \
@@ -88,8 +89,7 @@ check: build
dh_testdir
ifeq (,$(filter nocheck,$(DEB_BUILD_OPTIONS)))
- cd build-tree && $(MAKE) VERBOSE=1 TESTSUITEFLAGS=--verbose \
- TEST_PARALLEL=$(NUMJOBS) check
+ cd build-tree && $(MAKE) $(testflags) TEST_PARALLEL=$(NUMJOBS) check
endif
# Install the package underneath debian/tmp
@@ -101,6 +101,11 @@ install: check
cd build-tree && $(MAKE) DESTDIR=$(D) install
+ # Special-case the lintian profile, as dh cannot rename on install.
+ mkdir -p $(D)/usr/share/lintian/profiles/dpkg
+ cp debian/dpkg.lintian-profile \
+ $(D)/usr/share/lintian/profiles/dpkg/main.profile
+
define dpkg-installmanl10n
for f in `sed -e 's:\*:*/*:' debian/$(1).manpages`; do \
test -e $$f && \
@@ -128,6 +133,7 @@ endif
$(call dpkg-installmanl10n,dselect)
dh_installman -a
dh_link -a
+ dh_bugfiles -a -A
dh_lintian -a
dh_strip -a
dh_compress -a
@@ -149,6 +155,7 @@ binary-indep: install
$(call dpkg-installmanl10n,dpkg-dev)
dh_installman -i
dh_link -i
+ dh_bugfiles -i -A
dh_lintian -i
# The perl modules should not depend on a specific interpreter.
dh_perl -i -Nlibdpkg-perl
@@ -168,6 +175,7 @@ clean:
[ ! -f Makefile ] || $(MAKE) distclean
rm -rf build-tree
+ dh_autoreconf_clean
dh_clean